SOL009 NFVMANO Log Management - Implementation of deltas between v4.4.1 and v4.3.1

This merge request refers to the implementation of deltas between v4.4.1 and v4.3.1 of SOL009 NFVMANO Log Management Interface.

Deadline for review: Thursday 09th May 2024 @6pm CEST

Edited by Giacomo Bernini

Merge request reports

Loading
+79 −23
Changes for SOL009/NFVMANOLogManagement-API/schemas/LoggingJob.schema.json: 79 added lines, 23 removed lines.
Original line number Diff line number Diff line
{
  "description": "This type represents a logging job. It shall comply with the provisions defined in table 8.6.2.6-1.",
  "type": "object",
  "required": ["id", "objectInstanceIds", "jobCriteria", "jobConfig", "_links"],
  "required": [
    "id",
    "objectInstanceIds",
    "jobCriteria",
    "jobConfig",
    "_links"
  ],
  "properties": {
    "id": {
      "description": "An identifier with the intention of being globally unique.\n",
@@ -34,28 +40,43 @@
            "type": "string"
          }
        },
        "required": ["type", "objectId"]
        "required": [
          "type",
          "objectId"
        ]
      }
    },
    "jobCriteria": {
      "description": "This type represents collection criteria for logging jobs. * NOTE:\tThe value of the loggingType has dependency on the object that is requested to be logged\n        (refer to the CreateLoggingJobRequest): a) the logging of messages is only applicable to\n        ManoServiceInterface and ConsumedManoInterface objects.",
      "type": "object",
      "required": ["loggingType"],
      "required": [
        "loggingType"
      ],
      "properties": {
        "loggingType": {
          "description": "Type of logging. This defines the types of logged information to collect.\nPermitted values: - MESSAGES: logged NFV-MANO service interface messages. - SERVICES: logged messages about processes pertaining to NFV-MANO services. - SYSTEM: logged messages about the NFV-MANO functional entityΓÇÖs system enabled by the provider.\nSee note.",
          "description": "Type of logging. This defines the types of logged information to collect.\nPermitted values: - MESSAGES: logged NFV-MANO service interface messages. - SERVICES: logged messages about processes pertaining to NFV-MANO services. - SYSTEM: logged messages about the NFV-MANO functional entity’s system enabled by the provider.\nSee note.",
          "type": "string",
          "enum": ["MESSAGES", "SERVICES", "SYSTEM"]
          "enum": [
            "MESSAGES",
            "SERVICES",
            "SYSTEM"
          ]
        },
        "messagesLogDetail": {
          "description": "This type represents criteria for logging jobs to collect logged messages on NFV-MANO service interfaces. * NOTE:\tIf a matching pattern is present, at least one of the \"srcIpAddress\", \"dstIpAddress\", \"requestMethod\",\n        \"requestUriPattern\" or \"responseCodes\" shall be provided.",
          "type": "object",
          "required": ["direction"],
          "required": [
            "direction"
          ],
          "properties": {
            "direction": {
              "description": "The direction of the interface messages to match.\nPermitted values: - IN: input messages into the interface. - OUT: output messages from the interface. - ALL: both input and output messages into/from the interface.",
              "type": "string",
              "enum": ["IN", "OUT", "ALL"]
              "enum": [
                "IN",
                "OUT",
                "ALL"
              ]
            },
            "matchingPatterns": {
              "description": "Patterns to be matched in the interface message. If provided, only messages that match all the values provided in the sub-attributes shall be logged. An API consumer can provide more than one \"matchingPattern\" if combinations of patterns are to be considered to match diverse sets of interface messages. See note.",
@@ -64,19 +85,29 @@
                "type": "object",
                "anyOf": [
                  {
                    "required": ["srcIpAddress"]
                    "required": [
                      "srcIpAddress"
                    ]
                  },
                  {
                    "required": ["dstIpAddress"]
                    "required": [
                      "dstIpAddress"
                    ]
                  },
                  {
                    "required": ["requestMethod"]
                    "required": [
                      "requestMethod"
                    ]
                  },
                  {
                    "required": ["requestUriPattern"]
                    "required": [
                      "requestUriPattern"
                    ]
                  },
                  {
                    "required": ["responseCodes"]
                    "required": [
                      "responseCodes"
                    ]
                  }
                ],
                "properties": {
@@ -86,7 +117,7 @@
                    "format": "IP"
                  },
                  "requestMethod": {
                    "description": "HTTP request method to be matched. To match, the HTTP request method of the message shall be the same as the value of this attribute. Valid values are specified in IETF RFC 7231. The API producer shall support this attribute.",
                    "description": "HTTP request method to be matched. To match, the HTTP request method of the message shall be the same as the value of this attribute. Valid values are specified in IETF RFC 9110 and IETF RFC 5789.  The API producer shall support this attribute.",
                    "type": "string"
                  },
                  "requestUriPattern": {
@@ -135,7 +166,10 @@
        "systemLogDetail": {
          "description": "This type represents criteria for logging jobs to collect logged system events of the NFV-MANO functional entity. * NOTE:\tThe set of properties and values for this attribute are assumed to be known to the consumer\n        by means defined outside of the present document.",
          "type": "object",
          "required": ["systemLogs", "severityLevel"],
          "required": [
            "systemLogs",
            "severityLevel"
          ],
          "properties": {
            "systemLogs": {
              "description": "This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of keyvalue pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 8259. In the following example, a list of key-value pairs with four keys (\"aString\", \"aNumber\", \"anArray\" and \"anObject\") is provided to illustrate that the values associated with different keys can be of different type.\n",
@@ -156,7 +190,10 @@
    "jobConfig": {
      "description": "This type represents configuration data for a logging job. It shall comply with the provisions defined in table 8.6.3.6-1. NOTE: The present document version does not specify the support for \"log compilation and reporting based on events\" as specified in clause 6.6.2.2 of ETSI GS NFV-IFA 031.\n* NOTE 1:\tThe minimumReportingPeriod is used to throttle possible flooding of reports by providing a lower\n            limit on the gap between two log availability notification to be emitted by the same logging job.\n  NOTE 2:\tMore than one logCompilingCondition is possible to provide a combination of different conditions\n            for the compilation. This covers use cases when the compilation of the log can be based on, e.g.\n            a timer value and a size value, whichever first condition is met first. For instance, compile a\n            log every 3 600 seconds, or whenever during the 3 600 seconds period the log grows in\n            size to 1 000 000 bytes.\n  NOTE 3:\tThe value is indicative, as the actual size of the compiled log files might not match the provided\n            compileBySizeValue due to possible deviations in the tracking of the size of the log data by the\n            API producer, and the size of individual logged data entries when these are collected.",
      "type": "object",
      "required": ["reportingCondition", "securityConf"],
      "required": [
        "reportingCondition",
        "securityConf"
      ],
      "properties": {
        "startTime": {
          "description": "Date-time stamp. Representation: String formatted according to IETF RFC 3339.\n",
@@ -170,12 +207,17 @@
        },
        "reportingCondition": {
          "description": "Specifies the condition under which the producer will report to the consumer about the compiled log data.",
          "required": ["reportingType"],
          "required": [
            "reportingType"
          ],
          "properties": {
            "reportingType": {
              "description": "Specifies the type of reporting condition. Permitted values: - REPORTING_ON_COMPILATION: the producer shall notify the consumer once the compilation of the\n                collected logging data into a file is completed and a new log report is available.\n- NO_REPORTING: no reporting is requested (the consumer can query the logging jobs to know about the\n                availability of new log reports).",
              "type": "string",
              "enum": ["REPORTING_ON_COMPILATION", "NO_REPORTING"]
              "enum": [
                "REPORTING_ON_COMPILATION",
                "NO_REPORTING"
              ]
            },
            "minimumReportingPeriod": {
              "description": "Specifies the minimum periodicity at which the producer will report to the consumer about the collected log information, in seconds. See note 1.",
@@ -200,7 +242,10 @@
          "properties": {
            "logFileEncryption": {
              "description": "Information about the encryption of the compiled log files. Shall be present if the log file is requested to be encrypted.",
              "required": ["encryptionCertificate", "cipherAlgorithm"],
              "required": [
                "encryptionCertificate",
                "cipherAlgorithm"
              ],
              "type": "object",
              "properties": {
                "encryptionCertificate": {
@@ -240,7 +285,10 @@
      "type": "array",
      "items": {
        "type": "object",
        "required": ["logReportId", "logReportLoc"],
        "required": [
          "logReportId",
          "logReportLoc"
        ],
        "properties": {
          "logReportId": {
            "description": "An identifier with the intention of being globally unique.\n",
@@ -249,7 +297,9 @@
          "logReportLoc": {
            "description": "This type represents a link to a resource using an absolute URI.\n",
            "type": "object",
            "required": ["href"],
            "required": [
              "href"
            ],
            "properties": {
              "href": {
                "description": "String formatted according to IETF RFC 3986.\n",
@@ -263,12 +313,16 @@
    "_links": {
      "description": "Links for this resource.",
      "type": "object",
      "required": ["self"],
      "required": [
        "self"
      ],
      "properties": {
        "self": {
          "description": "This type represents a link to a resource using an absolute URI.\n",
          "type": "object",
          "required": ["href"],
          "required": [
            "href"
          ],
          "properties": {
            "href": {
              "description": "String formatted according to IETF RFC 3986.\n",
@@ -282,7 +336,9 @@
          "items": {
            "description": "This type represents a link to a resource using an absolute URI.\n",
            "type": "object",
            "required": ["href"],
            "required": [
              "href"
            ],
            "properties": {
              "href": {
                "description": "String formatted according to IETF RFC 3986.\n",
+72 −22
Changes for SOL009/NFVMANOLogManagement-API/schemas/LoggingJobs.schema.json: 72 added lines, 22 removed lines.
Original line number Diff line number Diff line
@@ -42,28 +42,43 @@
              "type": "string"
            }
          },
          "required": ["type", "objectId"]
          "required": [
            "type",
            "objectId"
          ]
        }
      },
      "jobCriteria": {
        "description": "This type represents collection criteria for logging jobs. * NOTE:\tThe value of the loggingType has dependency on the object that is requested to be logged\n        (refer to the CreateLoggingJobRequest): a) the logging of messages is only applicable to\n        ManoServiceInterface and ConsumedManoInterface objects.",
        "type": "object",
        "required": ["loggingType"],
        "required": [
          "loggingType"
        ],
        "properties": {
          "loggingType": {
            "description": "Type of logging. This defines the types of logged information to collect.\nPermitted values: - MESSAGES: logged NFV-MANO service interface messages. - SERVICES: logged messages about processes pertaining to NFV-MANO services. - SYSTEM: logged messages about the NFV-MANO functional entityΓÇÖs system enabled by the provider.\nSee note.",
            "description": "Type of logging. This defines the types of logged information to collect.\nPermitted values: - MESSAGES: logged NFV-MANO service interface messages. - SERVICES: logged messages about processes pertaining to NFV-MANO services. - SYSTEM: logged messages about the NFV-MANO functional entity’s system enabled by the provider.\nSee note.",
            "type": "string",
            "enum": ["MESSAGES", "SERVICES", "SYSTEM"]
            "enum": [
              "MESSAGES",
              "SERVICES",
              "SYSTEM"
            ]
          },
          "messagesLogDetail": {
            "description": "This type represents criteria for logging jobs to collect logged messages on NFV-MANO service interfaces. * NOTE:\tIf a matching pattern is present, at least one of the \"srcIpAddress\", \"dstIpAddress\", \"requestMethod\",\n        \"requestUriPattern\" or \"responseCodes\" shall be provided.",
            "type": "object",
            "required": ["direction"],
            "required": [
              "direction"
            ],
            "properties": {
              "direction": {
                "description": "The direction of the interface messages to match.\nPermitted values: - IN: input messages into the interface. - OUT: output messages from the interface. - ALL: both input and output messages into/from the interface.",
                "type": "string",
                "enum": ["IN", "OUT", "ALL"]
                "enum": [
                  "IN",
                  "OUT",
                  "ALL"
                ]
              },
              "matchingPatterns": {
                "description": "Patterns to be matched in the interface message. If provided, only messages that match all the values provided in the sub-attributes shall be logged. An API consumer can provide more than one \"matchingPattern\" if combinations of patterns are to be considered to match diverse sets of interface messages. See note.",
@@ -72,19 +87,29 @@
                  "type": "object",
                  "anyOf": [
                    {
                      "required": ["srcIpAddress"]
                      "required": [
                        "srcIpAddress"
                      ]
                    },
                    {
                      "required": ["dstIpAddress"]
                      "required": [
                        "dstIpAddress"
                      ]
                    },
                    {
                      "required": ["requestMethod"]
                      "required": [
                        "requestMethod"
                      ]
                    },
                    {
                      "required": ["requestUriPattern"]
                      "required": [
                        "requestUriPattern"
                      ]
                    },
                    {
                      "required": ["responseCodes"]
                      "required": [
                        "responseCodes"
                      ]
                    }
                  ],
                  "properties": {
@@ -94,7 +119,7 @@
                      "format": "IP"
                    },
                    "requestMethod": {
                      "description": "HTTP request method to be matched. To match, the HTTP request method of the message shall be the same as the value of this attribute. Valid values are specified in IETF RFC 7231. The API producer shall support this attribute.",
                      "description": "HTTP request method to be matched. To match, the HTTP request method of the message shall be the same as the value of this attribute. Valid values are specified in IETF RFC 9110 and IETF RFC 5789.  The API producer shall support this attribute.",
                      "type": "string"
                    },
                    "requestUriPattern": {
@@ -143,7 +168,10 @@
          "systemLogDetail": {
            "description": "This type represents criteria for logging jobs to collect logged system events of the NFV-MANO functional entity. * NOTE:\tThe set of properties and values for this attribute are assumed to be known to the consumer\n        by means defined outside of the present document.",
            "type": "object",
            "required": ["systemLogs", "severityLevel"],
            "required": [
              "systemLogs",
              "severityLevel"
            ],
            "properties": {
              "systemLogs": {
                "description": "This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of keyvalue pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 8259. In the following example, a list of key-value pairs with four keys (\"aString\", \"aNumber\", \"anArray\" and \"anObject\") is provided to illustrate that the values associated with different keys can be of different type.\n",
@@ -164,7 +192,10 @@
      "jobConfig": {
        "description": "This type represents configuration data for a logging job. It shall comply with the provisions defined in table 8.6.3.6-1. NOTE: The present document version does not specify the support for \"log compilation and reporting based on events\" as specified in clause 6.6.2.2 of ETSI GS NFV-IFA 031.\n* NOTE 1:\tThe minimumReportingPeriod is used to throttle possible flooding of reports by providing a lower\n            limit on the gap between two log availability notification to be emitted by the same logging job.\n  NOTE 2:\tMore than one logCompilingCondition is possible to provide a combination of different conditions\n            for the compilation. This covers use cases when the compilation of the log can be based on, e.g.\n            a timer value and a size value, whichever first condition is met first. For instance, compile a\n            log every 3 600 seconds, or whenever during the 3 600 seconds period the log grows in\n            size to 1 000 000 bytes.\n  NOTE 3:\tThe value is indicative, as the actual size of the compiled log files might not match the provided\n            compileBySizeValue due to possible deviations in the tracking of the size of the log data by the\n            API producer, and the size of individual logged data entries when these are collected.",
        "type": "object",
        "required": ["reportingCondition", "securityConf"],
        "required": [
          "reportingCondition",
          "securityConf"
        ],
        "properties": {
          "startTime": {
            "description": "Date-time stamp. Representation: String formatted according to IETF RFC 3339.\n",
@@ -178,12 +209,17 @@
          },
          "reportingCondition": {
            "description": "Specifies the condition under which the producer will report to the consumer about the compiled log data.",
            "required": ["reportingType"],
            "required": [
              "reportingType"
            ],
            "properties": {
              "reportingType": {
                "description": "Specifies the type of reporting condition. Permitted values: - REPORTING_ON_COMPILATION: the producer shall notify the consumer once the compilation of the\n                collected logging data into a file is completed and a new log report is available.\n- NO_REPORTING: no reporting is requested (the consumer can query the logging jobs to know about the\n                availability of new log reports).",
                "type": "string",
                "enum": ["REPORTING_ON_COMPILATION", "NO_REPORTING"]
                "enum": [
                  "REPORTING_ON_COMPILATION",
                  "NO_REPORTING"
                ]
              },
              "minimumReportingPeriod": {
                "description": "Specifies the minimum periodicity at which the producer will report to the consumer about the collected log information, in seconds. See note 1.",
@@ -208,7 +244,10 @@
            "properties": {
              "logFileEncryption": {
                "description": "Information about the encryption of the compiled log files. Shall be present if the log file is requested to be encrypted.",
                "required": ["encryptionCertificate", "cipherAlgorithm"],
                "required": [
                  "encryptionCertificate",
                  "cipherAlgorithm"
                ],
                "type": "object",
                "properties": {
                  "encryptionCertificate": {
@@ -248,7 +287,10 @@
        "type": "array",
        "items": {
          "type": "object",
          "required": ["logReportId", "logReportLoc"],
          "required": [
            "logReportId",
            "logReportLoc"
          ],
          "properties": {
            "logReportId": {
              "description": "An identifier with the intention of being globally unique.\n",
@@ -257,7 +299,9 @@
            "logReportLoc": {
              "description": "This type represents a link to a resource using an absolute URI.\n",
              "type": "object",
              "required": ["href"],
              "required": [
                "href"
              ],
              "properties": {
                "href": {
                  "description": "String formatted according to IETF RFC 3986.\n",
@@ -271,12 +315,16 @@
      "_links": {
        "description": "Links for this resource.",
        "type": "object",
        "required": ["self"],
        "required": [
          "self"
        ],
        "properties": {
          "self": {
            "description": "This type represents a link to a resource using an absolute URI.\n",
            "type": "object",
            "required": ["href"],
            "required": [
              "href"
            ],
            "properties": {
              "href": {
                "description": "String formatted according to IETF RFC 3986.\n",
@@ -290,7 +338,9 @@
            "items": {
              "description": "This type represents a link to a resource using an absolute URI.\n",
              "type": "object",
              "required": ["href"],
              "required": [
                "href"
              ],
              "properties": {
                "href": {
                  "description": "String formatted according to IETF RFC 3986.\n",
+10 −10
Changes for SOL009/NFVMANOLogManagement-API/ApiVersion.robot: 10 added lines, 10 removed lines.
Original line number Diff line number Diff line
@@ -7,7 +7,7 @@ POST API Version - Method not implemented
    ...    Test title: POST API version - Method not implemented
    ...    Test objective: The objective is to test that POST method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none    
@@ -19,7 +19,7 @@ GET API Version
    ...    Test title: GET API Version
    ...    Test objective: The objective is to test that GET method successfully return ApiVersionInformation
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -32,7 +32,7 @@ PUT API Version - Method not implemented
    ...    Test title: PUT API Version - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -44,7 +44,7 @@ PATCH API Version - Method not implemented
    ...    Test title: PATCH API Version - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -56,7 +56,7 @@ DELETE API Version - Method not implemented
    ...    Test title: DELETE API Version - Method not implemented
    ...    Test objective: The objective is to test that DELETE method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -68,7 +68,7 @@ POST API Version with apiMajorVerion - Method not implemented
    ...    Test title: POST API version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that POST method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none    
@@ -80,7 +80,7 @@ GET API Version with apiMajorVerion
    ...    Test title: GET API Version with apiMajorVerion
    ...    Test objective: The objective is to test that GET method successfully return ApiVersionInformation
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -93,7 +93,7 @@ PUT API Version with apiMajorVerion - Method not implemented
    ...    Test title: PUT API Version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -105,7 +105,7 @@ PATCH API Version with apiMajorVerion - Method not implemented
    ...    Test title: PATCH API Version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -117,7 +117,7 @@ DELETE API Version with apiMajorVerion - Method not implemented
    ...    Test title: DELETE API Version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that DELETE method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none 
+10 −10
Changes for SOL009/NFVMANOLogManagement-API/CompileLogTask.robot: 10 added lines, 10 removed lines.
Original line number Diff line number Diff line
@@ -8,7 +8,7 @@ Request to compile the logged data into a file - Synchronous mode
    ...    Test title: Request to compile the logged data into a file - Synchronous mode
    ...    Test objective: The objective is to request to compile the logged data into a file in synchronous mode and perform a JSON schema validation on the returned log report data structure
    ...    Pre-conditions: logging job is available
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: The NFV-MANO can decide immediately what to respond to a compile request
    ...    Post-Conditions: none
@@ -22,7 +22,7 @@ Request to compile the logged data into a file - Asynchronous mode
    ...    Test title: Request to compile the logged data into a file - Asynchronous mode
    ...    Test objective: The objective is to request to compile the logged data into a file in asynchronous mode
    ...    Pre-conditions: logging job is available
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: The NFV-MANO can not decide immediately what to respond to a compile request
    ...    Post-Conditions: log report is available to the API consumer
@@ -36,7 +36,7 @@ Request to compile the logged data into a file - Already Processing
    ...    Test title: Request to compile the logged data into a file - Already Processing
    ...    Test objective: The objective is to request to compile the logged data into a file when a log data compilation and report creation is already ongoing, or a log report has just been created, for the specified logging job at the time of processing the request
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -44,12 +44,12 @@ Request to compile the logged data into a file - Already Processing
    Check HTTP Response Status Code Is    303
    Check HTTP Response Header Contains Location
    
Request to compile the logged data into a file with unprocessable entity
Request to compile the logged data into a file with unprocessable content
        [Documentation]    Test ID: 8.3.4.4.4
    ...    Test title: Request to compile the logged data into a file with unprocessable entity
    ...    Test title: Request to compile the logged data into a file with unprocessable content
    ...    Test objective:  The objective is to test that the rrequest to compile the logged data into a file fails when error in request body. 
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.1 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -62,7 +62,7 @@ GET Compiled Log Data - Method not implemented
    ...    Test title: GET Compiled Log Data - Method not implemented
    ...    Test objective: The objective is to test that GET method is not allowed to retrieve compiled log data.
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.6.3.2 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.2 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -74,7 +74,7 @@ PUT Compiled Log Data - Method not implemented
    ...    Test title: PUT Compiled Log Data - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not allowed to update compiled log data.
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.6.3.3 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.3 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -86,7 +86,7 @@ PATCH Compiled Log Data - Method not implemented
    ...    Test title: PATCH Compiled Log Data - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not allowed to update compiled log data.
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.6.3.4 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.4 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -98,7 +98,7 @@ DELETE Compiled Log Data - Method not implemented
    ...    Test title: DELETE Compiled Log Data - Method not implemented
    ...    Test objective: The objective is to test that DELETE method is not allowed to update compiled log data.
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.6.3.5 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.6.3.5 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
+7 −7
Changes for SOL009/NFVMANOLogManagement-API/IndividualLoggingJob.robot: 7 added lines, 7 removed lines.
Original line number Diff line number Diff line
@@ -7,7 +7,7 @@ POST Individual Logging Job - Method not implemented
    ...    Test title: POST Individual Logging Job - method not implemented
    ...    Test objective: The objective is to test that POST method is not allowed to create an Indiviual Logging
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.4.3.1 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.4.3.1 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -19,7 +19,7 @@ GET individual Logging Job
    ...    Test title: Get individual Logging Job
    ...    Test objective: The objective is to test the retrieval of an individual logging job and perform a JSON schema validation of the collected job data structure
    ...    Pre-conditions: Logging Job is already created.
    ...    Reference: clause 8.5.4.3.2 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.4.3.2 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -33,7 +33,7 @@ GET individual Logging Job with invalid resource identifier
    ...    Test title: Get individual Logging Job with invalid resource identifier
    ...    Test objective: The objective is to test that the retrieval of an individual logging job fails when using an invalid resource identifier, and perform the JSON schema validation of the failed operation HTTP response
    ...    Pre-conditions: Logging Job is already created.
    ...    Reference: clause 8.5.4.3.2 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.4.3.2 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -46,7 +46,7 @@ PUT Individual Logging Job - Method not implemented
    ...    Test title: PUT Individual Logging Job - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not allowed to update an existing Logging Job
    ...    Pre-conditions: none
    ...    Reference: clause 8.5.4.3.3 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.4.3.3 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -58,7 +58,7 @@ PATCH Individual Logging Job - Method not implemented
    ...    Test title: PATCH Individual Logging Job - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not allowed to modify an existing new Logging Job
    ...    Pre-conditions: none
    ...    Reference: clause 6.5.4.3.4 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 6.5.4.3.4 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -70,7 +70,7 @@ DELETE Individual Logging Job
    ...    Test title: DELETE Individual Logging Job
    ...    Test objective: The objective is to test the deletion of an individual logging job
    ...    Pre-conditions: Logging Job is already created.
    ...    Reference: clause 8.5.4.3.5 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.4.3.5 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: The Logging Job is no more available.   
@@ -83,7 +83,7 @@ DELETE Individual Logging Job with invalid resource identifier
    ...    Test title: DELETE Individual Logging Job with invalid resource identifier
    ...    Test objective: The objective is to test that the deletion of an individual logging job fails when using an invalid resource identifier
    ...    Pre-conditions: Logging Job is already created.
    ...    Reference: clause 8.5.4.3.5 - ETSI GS NFV-SOL 009 [7] v4.3.1
    ...    Reference: clause 8.5.4.3.5 - ETSI GS NFV-SOL 009 [7] v4.4.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
Loading
Loading