SOL005 NS Package management - Implementation of deltas between v4.4.1 and v4.3.1

This merge request refers to the implementation of deltas between v4.4.1 and v4.3.1 of SOL005 NS Package Management Interface.

Deadline for review: Thursday 09th May 2024 @6pm CEST

Merge request reports

Loading
+2 −11
Changes for SOL005/VNFPackageManagement-API/schemas/ExternalArtifactsAccessConfig.json: 2 added lines, 11 removed lines.
Original line number Diff line number Diff line
@@ -3,7 +3,7 @@
  "type": "object",
  "properties": {
    "artifact": {
        "description": "Access configuration information for an external artefact.\n",
      "description": "Access configuration information for an external artifact.\n",
      "type": "object",
      "required": [
        "artifactUri"
@@ -20,21 +20,12 @@
          "format": "uri"
        },
        "authType": {
            "description": "Defines the type of authentication / authorization for downloading the VNF package. Permitted values: - BASIC: Only the \"username\" and \"password\" attributes shall be present. - OAUTH2_CLIENT_CREDENTIAL S: Only the \"paramsOauth2ClientCredentials\" attribute shall be present. This attribute shall not be present if no credentials are provided for the artifact.\n",
          "description": "Defines the type of authentication / authorization for downloading the VNF package. Permitted values: - OAUTH2_CLIENT_CREDENTIALS:  Only the \"paramsOauth2ClientCredentials\" attribute shall be present. This attribute shall not be present if no credentials are provided for the artifact.\n",
          "type": "string",
          "enum": [
              "BASIC",
            "OAUTH2_CLIENT_CREDENTIALS"
          ]
        },
          "username": {
            "description": "User name to be used for authentication.\n",
            "type": "string"
          },
          "password": {
            "description": "Password to be used for authentication. Shall not be present in response bodies.\n",
            "type": "string"
          },
        "paramsOauth2ClientCredentials": {
          "description": "Parameters for authentication/authorization using OAUTH2_CLIENT_CREDENTIALS.\n",
          "type": "object",
+105 −22
Changes for SOL005/VNFPackageManagement-API/schemas/vnfPkgInfo.schema.json: 105 added lines, 22 removed lines.
Original line number Diff line number Diff line
{
	"description": "This type represents the information of a VNF package. It shall comply with the provisions defined in table 9.5.2.5-1.\nNOTE 1:\tIf the value of the onboardingState attribute is not equal to \"ONBOARDED\", the value of the operationalState attribute shall be equal to \"DISABLED\". NOTE 2:\tIf the value of the onboardingState attribute is not equal to \"ONBOARDED\", the value of the usageState attribute shall be equal to \"NOT_IN_USE\". NOTE 3:\tState changes of a VNF package are illustrated in clause B.2. NOTE 4:\tETSI GS NFV-SOL 001 specifies the structure and format of the VNFD based on TOSCA specifications.\n",
	"type": "object",
	"required": ["id", "onboardingState", "operationalState", "usageState", "vnfmInfo", "_links"],
	"required": [
	  "id",
	  "onboardingState",
	  "operationalState",
	  "usageState",
	  "_links"
	],
	"properties": {
	  "id": {
		"description": "An identifier with the intention of being globally unique.\n",
@@ -37,7 +43,10 @@
	  },
	  "checksum": {
		"description": "This type represents the checksum of a VNF package or an artifact file.\n",
			"required": ["algorithm", "hash"],
		"required": [
		  "algorithm",
		  "hash"
		],
		"type": "object",
		"properties": {
		  "algorithm": {
@@ -53,7 +62,10 @@
	  "packageSecurityOption": {
		"description": "Signals the security option used by the package as defined in clause 5.1 of ETSI GS NFV-SOL 004. It shall be present after  the VNF package content has been on-boarded  and absent otherwise. Valid values:  - OPTION_1 - OPTION_2\n",
		"type": "string",
			"enum": ["OPTION_1", "OPTION_2"]
		"enum": [
		  "OPTION_1",
		  "OPTION_2"
		]
	  },
	  "signingCertificate": {
		"description": "The singleton signing certificate if it is included as a file in the VNF package.\n",
@@ -63,8 +75,22 @@
		"description": "Information about VNF package artifacts that are software images. This attribute shall not be present before the VNF package content is on-boarded. Otherwise, this attribute shall be present unless it has been requested to be excluded per attribute selector.\n",
		"type": "array",
		"items": {
				"description": "This type represents an artifact contained in or external to a VNF package which represents a software image. NOTE 1:\tThe list of permitted values was taken from \"Container formats\" in OpenStack®: \"Disk and container formats for images\". NOTE 2:\tThe list of permitted values was adapted from \"Disk formats\" in OpenStack®: \"Disk and container formats for images\".\n",
				"required": ["id", "name", "provider", "version", "checksum", "isEncrypted", "containerFormat", "diskFormat", "createdAt", "minDisk", "minRam", "size", "imagePath"],
		  "description": "This type represents an artifact contained in or external to a VNF package which represents a software image. NOTE 1:\tThe list of permitted values was taken from \"Container formats\" in OpenStack®: \"Disk and container formats for images\". NOTE 2:\tThe list of permitted values was adapted from \"Disk formats\" in OpenStack®: \"Disk and container formats for images\".\n",
		  "required": [
			"id",
			"name",
			"provider",
			"version",
			"checksum",
			"isEncrypted",
			"containerFormat",
			"diskFormat",
			"createdAt",
			"minDisk",
			"minRam",
			"size",
			"imagePath"
		  ],
		  "type": "object",
		  "properties": {
			"id": {
@@ -85,7 +111,10 @@
			},
			"checksum": {
			  "description": "This type represents the checksum of a VNF package or an artifact file.\n",
						"required": ["algorithm", "hash"],
			  "required": [
				"algorithm",
				"hash"
			  ],
			  "type": "object",
			  "properties": {
				"algorithm": {
@@ -105,12 +134,31 @@
			"containerFormat": {
			  "description": "Container format indicates whether the software image is in a file format that also contains meta-data about the actual software. Permitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ram disk image format - BARE: the image does not have a container or meta-data envelope - DOCKER: docker container format - OVA: OVF package in a tar file - OVF: OVF container format\nSee note 1.\n",
			  "type": "string",
						"enum": ["AKI", "AMI", "ARI", "BARE", "DOCKER", "OVA", "OVF"]
			  "enum": [
				"AKI",
				"AMI",
				"ARI",
				"BARE",
				"DOCKER",
				"OVA",
				"OVF"
			  ]
			},
			"diskFormat": {
			  "description": "Disk format of a software image is the format of the underlying disk image. Permitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - ISO: an archive format for the data contents of an optical disc, such as CD-ROM - QCOW2: a common disk image format, which can expand dynamically and supports copy on write - RAW: an unstructured disk image format - VDI: a common disk image format - VHD: a common disk image format - VHDX: enhanced version of VHD format - VMDK: a common disk image format\nSee note 2.\n",
			  "type": "string",
						"enum": ["AKI", "AMI", "ARI", "ISO", "QCOW2", "RAW", "VDI", "VHD", "VHDX", "VMDK"]
			  "enum": [
				"AKI",
				"AMI",
				"ARI",
				"ISO",
				"QCOW2",
				"RAW",
				"VDI",
				"VHD",
				"VHDX",
				"VMDK"
			  ]
			},
			"createdAt": {
			  "description": "Date-time stamp. Representation: String formatted according toas defined by the date-time production in IETF RFC 3339.\n",
@@ -152,8 +200,11 @@
		"description": "Information about VNF package artifacts contained in the VNF package that are not software images. This attribute shall not be present before the VNF package content is on-boarded. Otherwise, this attribute shall be present if the VNF package contains additional artifacts.\n",
		"type": "array",
		"items": {
				"description": "This type represents an artifact other than a software image which is contained in or external to a VNF package. It shall comply with provisions defined in Table 9.5.3.3-1.\n",
				"required": ["isEncrypted", "checksum"],
		  "description": "This type represents an artifact other than a software image which is contained  in or external to a VNF package. It shall comply with provisions defined in  Table 9.5.3.3-1.\nNOTE: The attribute name \"artifactURI\" does not comply with the naming convention  defined in clause 4.3 of ETSI GS NFV-SOL 015. This is to maintain the backward  compatibility.\n",
		  "required": [
			"isEncrypted",
			"checksum"
		  ],
		  "type": "object",
		  "properties": {
			"artifactPath": {
@@ -167,7 +218,10 @@
			},
			"checksum": {
			  "description": "This type represents the checksum of a VNF package or an artifact file.\n",
						"required": ["algorithm", "hash"],
			  "required": [
				"algorithm",
				"hash"
			  ],
			  "type": "object",
			  "properties": {
				"algorithm": {
@@ -191,7 +245,11 @@
			"artifactClassification": {
			  "description": "Marks specific types of artifacts as defined in the VNF package. If none of the specific classes listed below applies, the attribute shall not be present. Valid values: - HISTORY: a history artifact as per clause 4.3.3 in ETSI GS NFV-SOL 004 - TESTING: a testing artifact as per clause 4.3.4 in ETSI GS NFV-SOL 004 - LICENSE: a license artifact as per clause 4.3.5 in ETSI GS NFV-SOL 004\n",
			  "type": "string",
						"enum": ["HISTORY", "TESTING", "LICENSE"]
			  "enum": [
				"HISTORY",
				"TESTING",
				"LICENSE"
			  ]
			},
			"metadata": {
			  "description": "This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159.\n",
@@ -203,20 +261,32 @@
	  "onboardingState": {
		"description": "The enumeration PackageOnboardingStateType shall comply with the provisions defined in Table 9.5.4.3-1. Permitted values: - CREATED: The VNF package resource has been created. - UPLOADING: The associated VNF package content is being uploaded. - PROCESSING: The associated VNF package content is being processed, e.g. validation. - ONBOARDED: The associated VNF package content is successfully on-boarded. - ERROR: There was an error during upload of the VNF package content or external artifacts, or during VNF package processing.\n",
		"type": "string",
			"enum": ["CREATED", "UPLOADING", "PROCESSING", "ONBOARDED", "ERROR"]
		"enum": [
		  "CREATED",
		  "UPLOADING",
		  "PROCESSING",
		  "ONBOARDED",
		  "ERROR"
		]
	  },
	  "operationalState": {
		"type": "string",
			"description": "\"The enumeration PackageOperationalStateType shall  comply with the provisions defined in Table 9.5.4.4-1.\" Acceptable values are: - ENABLED - The VNF package is enabled, i.e. it can be used for instantiation of new VNF instances. - DISABLED - The VNF package is disabled, i.e. it cannot be used for further VNF instantiation requests            (unless and until the VNF package is re-enabled).\n",
			"enum": ["ENABLED", "DISABLED"]
		"description": "\"The enumeration PackageOperationalStateType shall  comply with the provisions defined in Table 9.5.4.4-1.\" Acceptable values are: - ENABLED - The VNF package is enabled, i.e. it can be used for instantiation of new VNF instances. - DISABLED - The VNF package is disabled, i.e. it cannot be used for further VNF instantiation requests\n            (unless and until the VNF package is re-enabled).\n",
		"enum": [
		  "ENABLED",
		  "DISABLED"
		]
	  },
	  "usageState": {
		"type": "string",
		"description": "\"The enumeration PackageUsageStateType shall comply with the provisions. Acceptable values are: - IN_USE: \"Individual VNF instance\" resources created from this VNF package exist. - NOT_IN_USE: No \"individual VNF instance\" resource created from this VNF package exists.\n",
			"enum": ["IN_USE", "NOT_IN_USE"]
		"enum": [
		  "IN_USE",
		  "NOT_IN_USE"
		]
	  },
	  "vnfmInfo": {
			"description": "Specifies VNFMs compatible with the VNF. This information is copied from the VNFD. See note 4.\n",
		"description": "Specifies VNFMs compatible with the VNF. This information is copied from the VNFD of the on-boarded VNF package. See note 4. It shall be present after the VNF package content has been on-boarded and absent otherwise.\n",
		"type": "array",
		"items": {
		  "type": "string"
@@ -229,7 +299,10 @@
	  "onboardingFailureDetails": {
		"description": "The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 [19] is reproduced in this structure. Compared to the general framework defined in IETF RFC 7807 [19], the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 [19] foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807 [19].\n",
		"type": "object",
			"required": ["status", "detail"],
		"required": [
		  "status",
		  "detail"
		],
		"properties": {
		  "type": {
			"description": "A URI reference according to IETF RFC 3986 [5] that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
@@ -258,12 +331,18 @@
	  "_links": {
		"type": "object",
		"description": "Links to resources related to this resource.\n",
			"required": ["self", "packageContent", "vnfd"],
		"required": [
		  "self",
		  "packageContent",
		  "vnfd"
		],
		"properties": {
		  "self": {
			"description": "This type represents a link to a resource.\n",
			"type": "object",
					"required": ["href"],
			"required": [
			  "href"
			],
			"properties": {
			  "href": {
				"description": "URI of a resource referenced from a notification. Should be an absolute URI (i.e. a URI that contains {apiRoot}), however, may be a relative URI (i.e. a URI where the {apiRoot} part is omitted) if the {apiRoot} information is not available.\n",
@@ -275,7 +354,9 @@
		  "vnfd": {
			"description": "This type represents a link to a resource.\n",
			"type": "object",
					"required": ["href"],
			"required": [
			  "href"
			],
			"properties": {
			  "href": {
				"description": "URI of a resource referenced from a notification. Should be an absolute URI (i.e. a URI that contains {apiRoot}), however, may be a relative URI (i.e. a URI where the {apiRoot} part is omitted) if the {apiRoot} information is not available.\n",
@@ -287,7 +368,9 @@
		  "packageContent": {
			"description": "This type represents a link to a resource.\n",
			"type": "object",
					"required": ["href"],
			"required": [
			  "href"
			],
			"properties": {
			  "href": {
				"description": "URI of a resource referenced from a notification. Should be an absolute URI (i.e. a URI that contains {apiRoot}), however, may be a relative URI (i.e. a URI where the {apiRoot} part is omitted) if the {apiRoot} information is not available.\n",
+105 −22
Changes for SOL005/VNFPackageManagement-API/schemas/vnfPkgsInfo.schema.json: 105 added lines, 22 removed lines.
Original line number Diff line number Diff line
@@ -3,7 +3,13 @@
	"items": {
	  "description": "This type represents the information of a VNF package. It shall comply with the provisions defined in table 9.5.2.5-1.\nNOTE 1:\tIf the value of the onboardingState attribute is not equal to \"ONBOARDED\", the value of the operationalState attribute shall be equal to \"DISABLED\". NOTE 2:\tIf the value of the onboardingState attribute is not equal to \"ONBOARDED\", the value of the usageState attribute shall be equal to \"NOT_IN_USE\". NOTE 3:\tState changes of a VNF package are illustrated in clause B.2. NOTE 4:\tETSI GS NFV-SOL 001 specifies the structure and format of the VNFD based on TOSCA specifications.\n",
	  "type": "object",
		"required": ["id", "onboardingState", "operationalState", "usageState", "vnfmInfo", "_links"],
	  "required": [
		"id",
		"onboardingState",
		"operationalState",
		"usageState",
		"_links"
	  ],
	  "properties": {
		"id": {
		  "description": "An identifier with the intention of being globally unique.\n",
@@ -39,7 +45,10 @@
		},
		"checksum": {
		  "description": "This type represents the checksum of a VNF package or an artifact file.\n",
				"required": ["algorithm", "hash"],
		  "required": [
			"algorithm",
			"hash"
		  ],
		  "type": "object",
		  "properties": {
			"algorithm": {
@@ -55,7 +64,10 @@
		"packageSecurityOption": {
		  "description": "Signals the security option used by the package as defined in clause 5.1 of ETSI GS NFV-SOL 004. It shall be present after  the VNF package content has been on-boarded  and absent otherwise. Valid values:  - OPTION_1 - OPTION_2\n",
		  "type": "string",
				"enum": ["OPTION_1", "OPTION_2"]
		  "enum": [
			"OPTION_1",
			"OPTION_2"
		  ]
		},
		"signingCertificate": {
		  "description": "The singleton signing certificate if it is included as a file in the VNF package.\n",
@@ -65,8 +77,22 @@
		  "description": "Information about VNF package artifacts that are software images. This attribute shall not be present before the VNF package content is on-boarded. Otherwise, this attribute shall be present unless it has been requested to be excluded per attribute selector.\n",
		  "type": "array",
		  "items": {
					"description": "This type represents an artifact contained in or external to a VNF package which represents a software image. NOTE 1:\tThe list of permitted values was taken from \"Container formats\" in OpenStack®: \"Disk and container formats for images\". NOTE 2:\tThe list of permitted values was adapted from \"Disk formats\" in OpenStack®: \"Disk and container formats for images\".\n",
					"required": ["id", "name", "provider", "version", "checksum", "isEncrypted", "containerFormat", "diskFormat", "createdAt", "minDisk", "minRam", "size", "imagePath"],
			"description": "This type represents an artifact contained in or external to a VNF package which represents a software image. NOTE 1:\tThe list of permitted values was taken from \"Container formats\" in OpenStack®: \"Disk and container formats for images\". NOTE 2:\tThe list of permitted values was adapted from \"Disk formats\" in OpenStack®: \"Disk and container formats for images\".\n",
			"required": [
			  "id",
			  "name",
			  "provider",
			  "version",
			  "checksum",
			  "isEncrypted",
			  "containerFormat",
			  "diskFormat",
			  "createdAt",
			  "minDisk",
			  "minRam",
			  "size",
			  "imagePath"
			],
			"type": "object",
			"properties": {
			  "id": {
@@ -87,7 +113,10 @@
			  },
			  "checksum": {
				"description": "This type represents the checksum of a VNF package or an artifact file.\n",
							"required": ["algorithm", "hash"],
				"required": [
				  "algorithm",
				  "hash"
				],
				"type": "object",
				"properties": {
				  "algorithm": {
@@ -107,12 +136,31 @@
			  "containerFormat": {
				"description": "Container format indicates whether the software image is in a file format that also contains meta-data about the actual software. Permitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ram disk image format - BARE: the image does not have a container or meta-data envelope - DOCKER: docker container format - OVA: OVF package in a tar file - OVF: OVF container format\nSee note 1.\n",
				"type": "string",
							"enum": ["AKI", "AMI", "ARI", "BARE", "DOCKER", "OVA", "OVF"]
				"enum": [
				  "AKI",
				  "AMI",
				  "ARI",
				  "BARE",
				  "DOCKER",
				  "OVA",
				  "OVF"
				]
			  },
			  "diskFormat": {
				"description": "Disk format of a software image is the format of the underlying disk image. Permitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - ISO: an archive format for the data contents of an optical disc, such as CD-ROM - QCOW2: a common disk image format, which can expand dynamically and supports copy on write - RAW: an unstructured disk image format - VDI: a common disk image format - VHD: a common disk image format - VHDX: enhanced version of VHD format - VMDK: a common disk image format\nSee note 2.\n",
				"type": "string",
							"enum": ["AKI", "AMI", "ARI", "ISO", "QCOW2", "RAW", "VDI", "VHD", "VHDX", "VMDK"]
				"enum": [
				  "AKI",
				  "AMI",
				  "ARI",
				  "ISO",
				  "QCOW2",
				  "RAW",
				  "VDI",
				  "VHD",
				  "VHDX",
				  "VMDK"
				]
			  },
			  "createdAt": {
				"description": "Date-time stamp. Representation: String formatted according toas defined by the date-time production in IETF RFC 3339.\n",
@@ -154,8 +202,11 @@
		  "description": "Information about VNF package artifacts contained in the VNF package that are not software images. This attribute shall not be present before the VNF package content is on-boarded. Otherwise, this attribute shall be present if the VNF package contains additional artifacts.\n",
		  "type": "array",
		  "items": {
					"description": "This type represents an artifact other than a software image which is contained in or external to a VNF package. It shall comply with provisions defined in Table 9.5.3.3-1.\n",
					"required": ["isEncrypted", "checksum"],
			"description": "This type represents an artifact other than a software image which is contained  in or external to a VNF package. It shall comply with provisions defined in  Table 9.5.3.3-1.\nNOTE: The attribute name \"artifactURI\" does not comply with the naming convention  defined in clause 4.3 of ETSI GS NFV-SOL 015. This is to maintain the backward  compatibility.\n",
			"required": [
			  "isEncrypted",
			  "checksum"
			],
			"type": "object",
			"properties": {
			  "artifactPath": {
@@ -169,7 +220,10 @@
			  },
			  "checksum": {
				"description": "This type represents the checksum of a VNF package or an artifact file.\n",
							"required": ["algorithm", "hash"],
				"required": [
				  "algorithm",
				  "hash"
				],
				"type": "object",
				"properties": {
				  "algorithm": {
@@ -193,7 +247,11 @@
			  "artifactClassification": {
				"description": "Marks specific types of artifacts as defined in the VNF package. If none of the specific classes listed below applies, the attribute shall not be present. Valid values: - HISTORY: a history artifact as per clause 4.3.3 in ETSI GS NFV-SOL 004 - TESTING: a testing artifact as per clause 4.3.4 in ETSI GS NFV-SOL 004 - LICENSE: a license artifact as per clause 4.3.5 in ETSI GS NFV-SOL 004\n",
				"type": "string",
							"enum": ["HISTORY", "TESTING", "LICENSE"]
				"enum": [
				  "HISTORY",
				  "TESTING",
				  "LICENSE"
				]
			  },
			  "metadata": {
				"description": "This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159.\n",
@@ -205,20 +263,32 @@
		"onboardingState": {
		  "description": "The enumeration PackageOnboardingStateType shall comply with the provisions defined in Table 9.5.4.3-1. Permitted values: - CREATED: The VNF package resource has been created. - UPLOADING: The associated VNF package content is being uploaded. - PROCESSING: The associated VNF package content is being processed, e.g. validation. - ONBOARDED: The associated VNF package content is successfully on-boarded. - ERROR: There was an error during upload of the VNF package content or external artifacts, or during VNF package processing.\n",
		  "type": "string",
				"enum": ["CREATED", "UPLOADING", "PROCESSING", "ONBOARDED", "ERROR"]
		  "enum": [
			"CREATED",
			"UPLOADING",
			"PROCESSING",
			"ONBOARDED",
			"ERROR"
		  ]
		},
		"operationalState": {
		  "type": "string",
				"description": "\"The enumeration PackageOperationalStateType shall  comply with the provisions defined in Table 9.5.4.4-1.\" Acceptable values are: - ENABLED - The VNF package is enabled, i.e. it can be used for instantiation of new VNF instances. - DISABLED - The VNF package is disabled, i.e. it cannot be used for further VNF instantiation requests            (unless and until the VNF package is re-enabled).\n",
				"enum": ["ENABLED", "DISABLED"]
		  "description": "\"The enumeration PackageOperationalStateType shall  comply with the provisions defined in Table 9.5.4.4-1.\" Acceptable values are: - ENABLED - The VNF package is enabled, i.e. it can be used for instantiation of new VNF instances. - DISABLED - The VNF package is disabled, i.e. it cannot be used for further VNF instantiation requests\n            (unless and until the VNF package is re-enabled).\n",
		  "enum": [
			"ENABLED",
			"DISABLED"
		  ]
		},
		"usageState": {
		  "type": "string",
		  "description": "\"The enumeration PackageUsageStateType shall comply with the provisions. Acceptable values are: - IN_USE: \"Individual VNF instance\" resources created from this VNF package exist. - NOT_IN_USE: No \"individual VNF instance\" resource created from this VNF package exists.\n",
				"enum": ["IN_USE", "NOT_IN_USE"]
		  "enum": [
			"IN_USE",
			"NOT_IN_USE"
		  ]
		},
		"vnfmInfo": {
				"description": "Specifies VNFMs compatible with the VNF. This information is copied from the VNFD. See note 4.\n",
		  "description": "Specifies VNFMs compatible with the VNF. This information is copied from the VNFD of the on-boarded VNF package. See note 4. It shall be present after the VNF package content has been on-boarded and absent otherwise.\n",
		  "type": "array",
		  "items": {
			"type": "string"
@@ -231,7 +301,10 @@
		"onboardingFailureDetails": {
		  "description": "The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 [19] is reproduced in this structure. Compared to the general framework defined in IETF RFC 7807 [19], the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 [19] foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807 [19].\n",
		  "type": "object",
				"required": ["status", "detail"],
		  "required": [
			"status",
			"detail"
		  ],
		  "properties": {
			"type": {
			  "description": "A URI reference according to IETF RFC 3986 [5] that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
@@ -260,12 +333,18 @@
		"_links": {
		  "type": "object",
		  "description": "Links to resources related to this resource.\n",
				"required": ["self", "packageContent", "vnfd"],
		  "required": [
			"self",
			"packageContent",
			"vnfd"
		  ],
		  "properties": {
			"self": {
			  "description": "This type represents a link to a resource.\n",
			  "type": "object",
						"required": ["href"],
			  "required": [
				"href"
			  ],
			  "properties": {
				"href": {
				  "description": "URI of a resource referenced from a notification. Should be an absolute URI (i.e. a URI that contains {apiRoot}), however, may be a relative URI (i.e. a URI where the {apiRoot} part is omitted) if the {apiRoot} information is not available.\n",
@@ -277,7 +356,9 @@
			"vnfd": {
			  "description": "This type represents a link to a resource.\n",
			  "type": "object",
						"required": ["href"],
			  "required": [
				"href"
			  ],
			  "properties": {
				"href": {
				  "description": "URI of a resource referenced from a notification. Should be an absolute URI (i.e. a URI that contains {apiRoot}), however, may be a relative URI (i.e. a URI where the {apiRoot} part is omitted) if the {apiRoot} information is not available.\n",
@@ -289,7 +370,9 @@
			"packageContent": {
			  "description": "This type represents a link to a resource.\n",
			  "type": "object",
						"required": ["href"],
			  "required": [
				"href"
			  ],
			  "properties": {
				"href": {
				  "description": "URI of a resource referenced from a notification. Should be an absolute URI (i.e. a URI that contains {apiRoot}), however, may be a relative URI (i.e. a URI where the {apiRoot} part is omitted) if the {apiRoot} information is not available.\n",
+16 −16
Changes for SOL005/VNFPackageManagement-API/AccessConfigurationForExternalArtifacts.robot: 16 added lines, 16 removed lines.
Original line number Diff line number Diff line
@@ -7,11 +7,11 @@ Library REST ${NFVO_SCHEMA}://${NFVO_HOST}:${NFVO_PORT} ssl_veri

*** Test Cases ***
Get Access configuration for external artifacts
    [Documentation]    Test ID: 5.3.5.10.1
    [Documentation]    Test ID: 5.3.5.11.1
    ...    Test title: Get Access configuration for external artifacts
    ...    Test objective: The objective is to test the GET method reads the access configuration information that is used by the NFVO to get the content of external VNF package artifacts and perform a JSON schema and content validation of the collected data structure
    ...    Pre-conditions: One or more VNF packages are onboarded in the NFVO.
    ...    Reference: Clause 9.4.4a.3.2 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.2 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -20,11 +20,11 @@ Get Access configuration for external artifacts
    Check HTTP Response Body Json Schema Is   ExternalArtifactsAccessConfig

Get Access configuration for external artifacts - Not Found
    [Documentation]    Test ID: 5.3.5.10.2
    [Documentation]    Test ID: 5.3.5.11.2
    ...    Test title: Get Access configuration for external artifacts - Not Found
    ...    Test objective: The objective is to test that the retrieval of access configuration information that is used by the NFVO to get the content of external VNF package artifacts fails because resource is not present.
    ...    Pre-conditions: none
    ...    Reference: Clause 9.4.4a.3.2 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.2 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -33,11 +33,11 @@ Get Access configuration for external artifacts - Not Found
    Check HTTP Response Body Json Schema Is   ProblemDetails
    
PUT Access configuration for external artifacts 
    [Documentation]    Test ID: 5.3.5.10.3
    [Documentation]    Test ID: 5.3.5.11.3
    ...    Test title: Access configuration for external artifacts
    ...    Test objective: The objective is to test that PUT method provides the access configuration information for the NFVO to download the content of external VNF package artifacts.
    ...    Pre-conditions:  the individual VNF package resource shall have been created, and the value of "onboardingState" attribute shall equal to "CREATED" or "ERROR"
    ...    Reference: Clause 9.4.4a.3.3 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.3 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -47,11 +47,11 @@ PUT Access configuration for external artifacts
    Check HTTP Response Body Json Schema Is   ExternalArtifactsAccessConfig
    
PUT Access configuration for external artifacts - Downloading
    [Documentation]    Test ID: 5.3.5.10.4
    [Documentation]    Test ID: 5.3.5.11.4
    ...    Test title: Access configuration for external artifacts - Downloading
    ...    Test objective: The objective is to test that VNF package has been uploaded successfully previously, to indicate that the access configuration information has been stored successfully by the NFVO and the NFVO now starts downloading external artifacts.
    ...    Pre-conditions:  the individual VNF package resource shall have been created, and the value of "onboardingState" attribute shall equal to "CREATED" or "ERROR"
    ...    Reference: Clause 9.4.4a.3.3 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.3 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -60,11 +60,11 @@ PUT Access configuration for external artifacts - Downloading
    Check HTTP Response Status Code Is    202
    
PUT Access configuration for external artifacts - Conflict
    [Documentation]    Test ID: 5.3.5.10.5
    [Documentation]    Test ID: 5.3.5.11.5
    ...    Test title: Access configuration for external artifacts
    ...    Test objective: The objective is to test that PUT method provides the access configuration information for the NFVO to download the content of external VNF package artifacts.
    ...    Pre-conditions:  the individual VNF package resource shall have been created, and the value of "onboardingState" attribute is neither "CREATED" nor "ERROR"
    ...    Reference: Clause 9.4.4a.3.3 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.3 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -73,11 +73,11 @@ PUT Access configuration for external artifacts - Conflict
    Check HTTP Response Body Json Schema Is   ProblemDetails
    
POST Access configuration for external artifacts - Method not implemented
    [Documentation]    Test ID: 5.3.5.10.6
    [Documentation]    Test ID: 5.3.5.11.6
    ...    Test title: POST Access configuration for external artifacts - Method not implemented
    ...    Test objective: The objective is to test that POST method is not allowed to create access configuration for external artifacts
    ...    Pre-conditions: none
    ...    Reference: Clause 9.4.4a.3.1 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.1 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -85,11 +85,11 @@ POST Access configuration for external artifacts - Method not implemented
    Check HTTP Response Status Code Is    405

PATCH Access configuration for external artifacts - Method not implemented
    [Documentation]    Test ID: 5.3.5.10.7
    [Documentation]    Test ID: 5.3.5.11.7
    ...    Test title: PATCH Access configuration for external artifacts - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not allowed to update access configuration for external artifacts
    ...    Pre-conditions: none
    ...    Reference: Clause 9.4.4a.3.4 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.4 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -97,11 +97,11 @@ PATCH Access configuration for external artifacts - Method not implemented
    Check HTTP Response Status Code Is    405

DELETE Access configuration for external artifacts - Method not implemented
    [Documentation]    Test ID: 5.3.5.10.8
    [Documentation]    Test ID: 5.3.5.11.8
    ...    Test title: DELETE Access configuration for external artifacts - Method not implemented
    ...    Test objective: The objective is to test that DELETE  method is not allowed to delete access configuration for external artifacts
    ...    Pre-conditions: none
    ...    Reference: Clause 9.4.4a.3.5 - ETSI GS NFV-SOL 005 [3] v4.3.1
    ...    Reference: Clause 9.4.4a.3.5 - ETSI GS NFV-SOL 005 [3] v4.4.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
+10 −10
Changes for SOL005/VNFPackageManagement-API/ApiVersion.robot: 10 added lines, 10 removed lines.
Original line number Diff line number Diff line
@@ -12,7 +12,7 @@ POST API Version - Method not implemented
    ...    Test title: POST API version - Method not implemented
    ...    Test objective: The objective is to test that POST method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none    
@@ -24,7 +24,7 @@ GET API Version
    ...    Test title: GET API Version
    ...    Test objective: The objective is to test that GET method successfully return ApiVersionInformation
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -37,7 +37,7 @@ PUT API Version - Method not implemented
    ...    Test title: PUT API Version - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -49,7 +49,7 @@ PATCH API Version - Method not implemented
    ...    Test title: PATCH API Version - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -61,7 +61,7 @@ DELETE API Version - Method not implemented
    ...    Test title: DELETE API Version - Method not implemented
    ...    Test objective: The objective is to test that DELETE method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -73,7 +73,7 @@ POST API Version with apiMajorVerion - Method not implemented
    ...    Test title: POST API version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that POST method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.1 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none    
@@ -85,7 +85,7 @@ GET API Version with apiMajorVerion
    ...    Test title: GET API Version with apiMajorVerion
    ...    Test objective: The objective is to test that GET method successfully return ApiVersionInformation
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.2 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -98,7 +98,7 @@ PUT API Version with apiMajorVerion - Method not implemented
    ...    Test title: PUT API Version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.3 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -110,7 +110,7 @@ PATCH API Version with apiMajorVerion - Method not implemented
    ...    Test title: PATCH API Version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that PATCH method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.4 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
@@ -122,7 +122,7 @@ DELETE API Version with apiMajorVerion - Method not implemented
    ...    Test title: DELETE API Version with apiMajorVerion - Method not implemented
    ...    Test objective: The objective is to test that DELETE method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.3.1
    ...    Reference: Clause 9.3.3.3.5 - ETSI GS NFV-SOL 013 [5] v4.4.1
    ...    Config ID: Config_prod_VNFM
    ...    Applicability: none
    ...    Post-Conditions: none 
Loading
Loading