SOL003 VNF Snapshot Package Management - Implementation of deltas between v3.5.1 and v3.3.1

This merge request refers to the implementation of deltas between v3.5.1 and v3.3.1 of SOL003 VNF Snapshot Package Management Interface.

@lynchpi @aelken @matsuurat @sayama @kraja @zafar @abbasim @muhammadh

Deadline for review: Friday 5th November 2021 @6pm CEST

Review period elapsed: Approved !

Edited by Giacomo Bernini

Merge request reports

Loading
+0 −61
Changes for SOL003/VNFSnapshotPackageManagement-API/environment/variables.txt: 0 added lines, 61 removed lines.
Original line number Diff line number Diff line
@@ -7,70 +7,19 @@ ${AUTHORIZATION_TOKEN} Bearer 0b79bab50daca910b000d4f1a2b675d604257e42
${ACCEPT_JSON}    application/json
${AUTH_USAGE}     1
${CONTENT_TYPE_JSON}    application/json
${NEG_AUTHORIZATION}    Bearer negativetoken
${NFVO_FIELDS}    1

${vnfPackageId}  788106a2-d692-44f3-a86d-384f0ce35e42
${vndId}          788106a2-d692-44f3-a86d-384f0ce35e42
${onboardingStateVnfPkgId}    f9f130e4-05eb-4082-a676-4c97d13a883d    
${onboardingStateVnfdId}    f9f130e4-05eb-4082-a676-4c97d13a883d  

${apiRoot}        /
${apiMajorVersion}     v1
${apiName}        vnfsnapshotpkgm

${NFVO_CHECKS_NOTIF_ENDPOINT}    1        ## If true, during subscription, the FUT performs a get to the notification endpoint

${NFVO_ALLOWS_DUPLICATE_SUBS}    1

${PAGING_SUPPORTED}    1

${response}    httpresponse

${MOCK_SERVER_JAR}    ../../../bin/mockserver-netty-5.5.0-jar-with-dependencies.jar

${callback_uri}    http://localhost
${callback_port}    9091
${callback_endpoint}    /endpoint
${callback_endpoint_fwd}    /endpoint/check
${callback_endpoint_error}    /endpoint_404
${sleep_interval}    20s
${total_polling_time}   2 min
${polling_interval}     10 sec


${notification_request}    []
${notification_response}    []

${NFVO_non-MANO_OK}    1    # If 1 means that non-MANO artifacts are supported by the NFVO
${non_mano_artifact_sets}    


${subscriptionId}    f3ae6df7-07e1-47c9-8924-9ebe10343586
${erroneousSubscriptionId}    442e3ee5-0499-4849-9b31-eb91ce1638f1    # Not existing ID on the subscriptions
${newSubscriptionId}    newSubsciptionId

${origResponse}    httpresponse


${erroneousVnfPackageId}    erroneousVnfPackageId    # Given ID for vnfPkg not present in database
${erroneousVnfdId}    erroneousVnfdId 


${filter_ok}      callbackUri=http://172.22.1.7:9091/vnfpkgm/subscriptions
${filter_ko}      nfvId=f9f130e4-05eb-4082-a676-4c97d13a883d    # Not existant filter attribute-based
${SEPERATOR}      =


${ACCEPT_PLAIN}    text/plain
${CONTENT_TYPE_PLAIN}    text/plain
${vnfPkgPlainVNFD}    c26ad7fb-072b-48c4-a663-7d71646d9e98    # The VNF Pakcage contains a VNFD which is a Single Plain File
${ACCEPT_ZIP}     application/zip
${ACCEPT_OCTET}    application/octet-stream
${CONTENT_TYPE_ZIP}    application/zip
${vnfPkgZipVNFD}    f5b220d4-6177-4ebb-a554-a43311e16075    # The VNF Package contains a VNFD composed by multiple files
${erroneousVnfPkgId}    erroneousVnfPackageId    # Given ID for vnfPkg not present in database
${vndIdZipVnfd}       f5b220d4-6177-4ebb-a554-a43311e16075 


${artifactPath}    artifactPath
@@ -79,20 +28,10 @@ ${NFVO_RANGE_OK} 1 # If 1 means that Range is supported by the NFVO
${range}          bytes=0-1023
${full_length}        2000            # Size of the requested artifact to be downloaded via partial downloads
${erroneousRange}    bytes=10000000-1000000000    # Requesting a out of range number of bytes
${vnfPackageOctetStreamId}    octetStreamPkgId
${vnfdOctetStreamId}    octetStreamVnfdId
${vndEncryptedArtifactID}    encryptedId


${length}          1024

${POS_FILTER}     id=41fdd38a-3d4c-465c-83e0-f80e014425f8 ,vnfProvider=NXW    # Positive case, suing compiant fields name for filtering get request
${NEG_FILTER}     nfvId=41fdd38a-3d4c-465c-83e0-f80e014425f8    # Negative case, using wrong name of field
${fields}         failureDetails
${VAR_SEPERATOR}    &

${callbackResp}    localhost

${vnfSnapshotPkgId}
${invalidVnfSnapshotPkgId}
${vnfSnapshotPkgId_notInAvailableState}
 No newline at end of file
+24 −101
Changes for SOL003/VNFSnapshotPackageManagement-API/schemas/VnfSnapshotPkgInfo.schema.json: 24 added lines, 101 removed lines.
Original line number Diff line number Diff line
{
	"description": "This type represents the information of a VNF snapshot package.\n",
	"description": "This type represents the information of a VNF snapshot package. It shall comply with the provisions defined in table 12.5.2.2-1.\nNOTE:\tThe attribute shall not be present before the VNF snapshot package content has been uploaded or built. Otherwise, this \n      attribute shall be present unless it has been requested to be excluded per attribute selector.\n",
	"type": "object",
	"required": [
		"id",
		"name",
		"isFullSnapshot",
		"state",
		"isCancelPending",
		"_links"
	],
	"required": ["id", "name", "isFullSnapshot", "state", "isCancelPending", "_links"],
	"properties": {
		"id": {
			"description": "An identifier with the intention of being globally unique.\n",
@@ -36,7 +29,7 @@
			"type": "string"
		},
		"vnfcSnapshotInfoIds": {
			"description": "Identifiers of information held by the VNFM about specific VNFC snapshots part  of the VNF snapshot and contained in the VNF snapshot package. This identifier  is allocated by the VNFM during the VNF snapshot creation.\nNOTE: The attribute shall not be present before the VNF snapshot package content  has been uploaded or built. Otherwise, this attribute shall be present unless it  has been requested to be excluded per attribute selector.\n",
			"description": "Identifiers of information held by the VNFM about specific VNFC snapshots part  of the VNF snapshot and contained in the VNF snapshot package. This identifier  is allocated by the VNFM during the VNF snapshot creation.\nSee note.\n",
			"type": "object",
			"items": {
				"description": "An identifier that is unique within a limited local scope other than above listed identifiers, such as within a complex data structure or within a request-response pair. Representation: string of variable length.\n",
@@ -50,12 +43,7 @@
		"vnfdInfo": {
			"description": "This type represents the VNFD which is contained in a VNF snapshot package.\n",
			"type": "object",
			"required": [
				"avnfdId",
				"vnfdPath",
				"checksum",
				"isEncrypted"
			],
			"required": ["avnfdId", "vnfdPath", "checksum", "isEncrypted"],
			"properties": {
				"avnfdId": {
					"description": "An identifier with the intention of being globally unique.\n",
@@ -78,11 +66,7 @@
		"vnfsr": {
			"description": "This type represents the VNF snapshot record which is contained in a VNF snapshot package.\n",
			"type": "object",
			"required": [
				"recordPath",
				"checksum",
				"isEncrypted"
			],
			"required": ["recordPath", "checksum", "isEncrypted"],
			"properties": {
				"recordPath": {
					"description": "A string defined in IETF RFC 8259.\n",
@@ -99,24 +83,12 @@
			}
		},
		"vnfcSnapshotImages": {
			"description": "Information about VNF snapshot artifacts that are VNFC snapshot images. Every local and  external snapshot image shall be included. No other artifacts shall be included.\nNOTE: The attribute shall not be present before the VNF snapshot package content  has been uploaded or built. Otherwise, this attribute shall be present unless it  has been requested to be excluded per attribute selector.\n",
			"description": "Information about VNF snapshot artifacts that are VNFC snapshot images. Every local and  external snapshot image shall be included. No other artifacts shall be included.\nSee note.\n",
			"type": "object",
			"items": {
				"description": "This type represents an artifact contained in a VNF snapshot package which  represents a snapshot image.\n",
				"description": "This type represents an artifact contained in a VNF snapshot package which represents a snapshot image.  It shall comply with the provisions defined in table 12.5.3.2-1.\nNOTE 1:\tThe list of permitted values was taken from \"Container formats\" in OpenStack® documentation: \"Disk and container formats for images\"\n        (Available at https://docs.openstack.org/glance/pike/user/formats.html).\nNOTE 2:\tThe list of permitted values was adapted from \"Disk formats\" in OpenStack® documentation: \"Disk and container formats for images\"\n        (Available at https://docs.openstack.org/glance/pike/user/formats.html).\n",
				"type": "object",
				"required": [
					"id",
					"name",
					"checksum",
					"isEncrypted",
					"vnfcInstanceId",
					"containerFormat",
					"diskFormat",
					"createdAt",
					"minDisk",
					"minRam",
					"size"
				],
				"required": ["id", "name", "checksum", "isEncrypted", "vnfcInstanceId", "containerFormat", "diskFormat", "createdAt", "minDisk", "minRam", "size"],
				"properties": {
					"id": {
						"description": "An identifier that is unique within a limited local scope other than above listed identifiers, such as within a complex data structure or within a request-response pair. Representation: string of variable length.\n",
@@ -139,33 +111,14 @@
						"type": "string"
					},
					"containerFormat": {
						"description": "Container format indicates whether the snapshot image is in a file format that  also contains metadata about the actual snapshot.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - BARE: the image does not have a container or metadata envelope - DOCKER: docker container format - OVA: OVF package in a tarfile - OVF: OVF container format\nNOTE: The list of permitted values was taken from \"Container formats\" in [i.5] (OpenStack® documentation: \"Disk and container formats for images\").\n",
						"description": "Container format indicates whether the snapshot image is in a file format that  also contains metadata about the actual snapshot.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - BARE: the image does not have a container or metadata envelope - DOCKER: docker container format - OVA: OVF package in a tarfile - OVF: OVF container format\nSee note 1.\n",
						"type": "string",
						"enum": [
							"AKI",
							"AMI",
							"ARI",
							"BARE",
							"DOCKER",
							"OVA",
							"OVF"
						]
						"enum": ["AKI", "AMI", "ARI", "BARE", "DOCKER", "OVA", "OVF"]
					},
					"diskFormat": {
						"description": "Disk format of a snapshot image is the format of the underlying disk image.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - ISO: an archive format for the data contents of an optical disc, such as CD-ROM - QCOW2: a common disk image format, which can expand dynamically and supports copy on write - RAW: an unstructured disk image format - VDI: a common disk image format - VHD: a common disk image format - VHDX: enhanced version of VHD format - VMDK: a common disk image format\nNOTE: The list of permitted values was adapted from \"Disk formats\" in [i.5] (OpenStack® documentation: \"Disk and container formats for images\").\n",
						"description": "Disk format of a snapshot image is the format of the underlying disk image.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - ISO: an archive format for the data contents of an optical disc, such as CD-ROM - QCOW2: a common disk image format, which can expand dynamically and supports copy on write - RAW: an unstructured disk image format - VDI: a common disk image format - VHD: a common disk image format - VHDX: enhanced version of VHD format - VMDK: a common disk image format\nSee note 2.\n",
						"type": "string",
						"enum": [
							"AKI",
							"AMI",
							"ARI",
							"ISO",
							"QCOW2",
							"RAW",
							"VDI",
							"VHD",
							"VHDX",
							"VMDK"
						]
						"enum": ["AKI", "AMI", "ARI", "ISO", "QCOW2", "RAW", "VDI", "VHD", "VHDX", "VMDK"]
					},
					"createdAt": {
						"description": "Date-time stamp. Representation: String formatted according to IETF RFC 3339.\n",
@@ -203,15 +156,12 @@
			}
		},
		"additionalArtifacts": {
			"description": "Information about VNF snapshot artifacts that are not VNFC snapshot images.\nNOTE: The attribute shall not be present before the VNF snapshot package content  has been uploaded or built. Otherwise, this attribute shall be present unless it  has been requested to be excluded per attribute selector.\n",
			"description": "Information about VNF snapshot artifacts that are not VNFC snapshot images.\nSee note.\n",
			"type": "object",
			"items": {
				"description": "This type represents an artifact other than a software image which is contained in  a VNF snapshot package.\n",
				"type": "object",
				"required": [
					"checksum",
					"isEncrypted"
				],
				"required": ["checksum", "isEncrypted"],
				"properties": {
					"artifactPath": {
						"description": "A string defined in IETF RFC 8259.\n",
@@ -237,17 +187,9 @@
			}
		},
		"state": {
			"description": "State of the VNF snapshot package.  Permitted values: - CREATED: the VNF snapshot package information has been created. - BUILDING: the VNF snapshot package is being built. - UPLOADING: the VNF snapshot package is being uploaded. - EXTRACTING: the VNF snapshot package’s content is being extracted. - AVAILABLE: the VNF snapshot package is available (i.e., build or upload is completed). - ERROR: failure during the VNF snapshot package building, uploading or processing. - ERROR_EXTRACTING: failure during the VNF snapshot package extraction task.\n",
			"description": "State of the VNF snapshot package.  Permitted values: - CREATED: the VNF snapshot package information has been created. - BUILDING: the VNF snapshot package is being built. - UPLOADING: the VNF snapshot package is being uploaded. - EXTRACTING: the VNF snapshot package’s content is being extracted. - AVAILABLE: the VNF snapshot package is available (i.e., build or upload is completed). - PROCESSING: the VNF snapshot is being processed.  - ERROR: failure during the VNF snapshot package building, uploading or processing. - ERROR_EXTRACTING: failure during the VNF snapshot package extraction task.\n",
			"type": "string",
			"enum": [
				"CREATED",
				"BUILDING",
				"UPLOADING",
				"EXTRACTING",
				"AVAILABLE",
				"ERROR",
				"ERROR_EXTRACTING"
			]
			"enum": ["CREATED", "BUILDING", "UPLOADING", "EXTRACTING", "AVAILABLE", "PROCESSING", "ERROR", "ERROR_EXTRACTING"]
		},
		"isCancelPending": {
			"description": "The Boolean is a data type having two values (true and false).\n",
@@ -256,32 +198,20 @@
		"failureDetails": {
			"description": "Failure details associated to current error state of the VNF snapshot package state. If \"state\" is \"ERROR\" or \"ERROR_EXTRACTING\", this attribute shall be present unless  it has been requested to be excluded via an attribute selector.\n",
			"type": "object",
			"required": [
				"errorType",
				"details"
			],
			"required": ["errorType", "details"],
			"properties": {
				"errorType": {
					"description": "Type of error, when the failure happened (building, upload, processing, extracting).\nPermitted values: - BUILD_ERROR - UPLOAD_ERROR - PROCESS_ERROR - CANCELLED - EXTRACTION_ERROR\n",
					"type": "string",
					"enum": [
						"BUILD_ERROR",
						"UPLOAD_ERROR",
						"PROCESS_ERROR",
						"CANCELLED",
						"EXTRACTION_ERROR"
					]
					"enum": ["BUILD_ERROR", "UPLOAD_ERROR", "PROCESS_ERROR", "CANCELLED", "EXTRACTION_ERROR"]
				},
				"details": {
					"description": "The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 [19] is reproduced inthis structure. Compared to the general framework defined in IETF RFC 7807 [19], the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 [19] foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807 [19].\n",
					"description": "The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 is reproduced inthis structure. Compared to the general framework defined in IETF RFC 7807, the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807.\n",
					"type": "object",
					"required": [
						"status",
						"detail"
					],
					"required": ["status", "detail"],
					"properties": {
						"type": {
							"description": "A URI reference according to IETF RFC 3986 [5] that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
							"description": "A URI reference according to IETF RFC 3986 that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
							"type": "string",
							"format": "URI"
						},
@@ -313,17 +243,12 @@
		"_links": {
			"description": "Links to resources related to this resource.\n",
			"type": "object",
			"required": [
				"self",
				"packageContent"
			],
			"required": ["self", "packageContent"],
			"properties": {
				"self": {
					"description": "This type represents a link to a resource using an absolute URI.\n",
					"type": "object",
					"required": [
						"href"
					],
					"required": ["href"],
					"properties": {
						"href": {
							"description": "String formatted according to IETF RFC 3986.\n",
@@ -334,9 +259,7 @@
				"packageContent": {
					"description": "This type represents a link to a resource using an absolute URI.\n",
					"type": "object",
					"required": [
						"href"
					],
					"required": ["href"],
					"properties": {
						"href": {
							"description": "String formatted according to IETF RFC 3986.\n",
+25 −103
Changes for SOL003/VNFSnapshotPackageManagement-API/schemas/VnfSnapshotPkgInfos.schema.json: 25 added lines, 103 removed lines.
Original line number Diff line number Diff line
{
	"type": "array",
  "items": 
  {
	"description": "This type represents the information of a VNF snapshot package.\n",
	"items": {
		"description": "This type represents the information of a VNF snapshot package. It shall comply with the provisions defined in table 12.5.2.2-1.\nNOTE:\tThe attribute shall not be present before the VNF snapshot package content has been uploaded or built. Otherwise, this \n      attribute shall be present unless it has been requested to be excluded per attribute selector.\n",
		"type": "object",
	"required": [
		"id",
		"name",
		"isFullSnapshot",
		"state",
		"isCancelPending",
		"_links"
	],
		"required": ["id", "name", "isFullSnapshot", "state", "isCancelPending", "_links"],
		"properties": {
			"id": {
				"description": "An identifier with the intention of being globally unique.\n",
@@ -39,7 +31,7 @@
				"type": "string"
			},
			"vnfcSnapshotInfoIds": {
			"description": "Identifiers of information held by the VNFM about specific VNFC snapshots part  of the VNF snapshot and contained in the VNF snapshot package. This identifier  is allocated by the VNFM during the VNF snapshot creation.\nNOTE: The attribute shall not be present before the VNF snapshot package content  has been uploaded or built. Otherwise, this attribute shall be present unless it  has been requested to be excluded per attribute selector.\n",
				"description": "Identifiers of information held by the VNFM about specific VNFC snapshots part  of the VNF snapshot and contained in the VNF snapshot package. This identifier  is allocated by the VNFM during the VNF snapshot creation.\nSee note.\n",
				"type": "object",
				"items": {
					"description": "An identifier that is unique within a limited local scope other than above listed identifiers, such as within a complex data structure or within a request-response pair. Representation: string of variable length.\n",
@@ -53,12 +45,7 @@
			"vnfdInfo": {
				"description": "This type represents the VNFD which is contained in a VNF snapshot package.\n",
				"type": "object",
			"required": [
				"avnfdId",
				"vnfdPath",
				"checksum",
				"isEncrypted"
			],
				"required": ["avnfdId", "vnfdPath", "checksum", "isEncrypted"],
				"properties": {
					"avnfdId": {
						"description": "An identifier with the intention of being globally unique.\n",
@@ -81,11 +68,7 @@
			"vnfsr": {
				"description": "This type represents the VNF snapshot record which is contained in a VNF snapshot package.\n",
				"type": "object",
			"required": [
				"recordPath",
				"checksum",
				"isEncrypted"
			],
				"required": ["recordPath", "checksum", "isEncrypted"],
				"properties": {
					"recordPath": {
						"description": "A string defined in IETF RFC 8259.\n",
@@ -102,24 +85,12 @@
				}
			},
			"vnfcSnapshotImages": {
			"description": "Information about VNF snapshot artifacts that are VNFC snapshot images. Every local and  external snapshot image shall be included. No other artifacts shall be included.\nNOTE: The attribute shall not be present before the VNF snapshot package content  has been uploaded or built. Otherwise, this attribute shall be present unless it  has been requested to be excluded per attribute selector.\n",
				"description": "Information about VNF snapshot artifacts that are VNFC snapshot images. Every local and  external snapshot image shall be included. No other artifacts shall be included.\nSee note.\n",
				"type": "object",
				"items": {
				"description": "This type represents an artifact contained in a VNF snapshot package which  represents a snapshot image.\n",
					"description": "This type represents an artifact contained in a VNF snapshot package which represents a snapshot image.  It shall comply with the provisions defined in table 12.5.3.2-1.\nNOTE 1:\tThe list of permitted values was taken from \"Container formats\" in OpenStack® documentation: \"Disk and container formats for images\"\n        (Available at https://docs.openstack.org/glance/pike/user/formats.html).\nNOTE 2:\tThe list of permitted values was adapted from \"Disk formats\" in OpenStack® documentation: \"Disk and container formats for images\"\n        (Available at https://docs.openstack.org/glance/pike/user/formats.html).\n",
					"type": "object",
				"required": [
					"id",
					"name",
					"checksum",
					"isEncrypted",
					"vnfcInstanceId",
					"containerFormat",
					"diskFormat",
					"createdAt",
					"minDisk",
					"minRam",
					"size"
				],
					"required": ["id", "name", "checksum", "isEncrypted", "vnfcInstanceId", "containerFormat", "diskFormat", "createdAt", "minDisk", "minRam", "size"],
					"properties": {
						"id": {
							"description": "An identifier that is unique within a limited local scope other than above listed identifiers, such as within a complex data structure or within a request-response pair. Representation: string of variable length.\n",
@@ -142,33 +113,14 @@
							"type": "string"
						},
						"containerFormat": {
						"description": "Container format indicates whether the snapshot image is in a file format that  also contains metadata about the actual snapshot.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - BARE: the image does not have a container or metadata envelope - DOCKER: docker container format - OVA: OVF package in a tarfile - OVF: OVF container format\nNOTE: The list of permitted values was taken from \"Container formats\" in [i.5] (OpenStack® documentation: \"Disk and container formats for images\").\n",
							"description": "Container format indicates whether the snapshot image is in a file format that  also contains metadata about the actual snapshot.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - BARE: the image does not have a container or metadata envelope - DOCKER: docker container format - OVA: OVF package in a tarfile - OVF: OVF container format\nSee note 1.\n",
							"type": "string",
						"enum": [
							"AKI",
							"AMI",
							"ARI",
							"BARE",
							"DOCKER",
							"OVA",
							"OVF"
						]
							"enum": ["AKI", "AMI", "ARI", "BARE", "DOCKER", "OVA", "OVF"]
						},
						"diskFormat": {
						"description": "Disk format of a snapshot image is the format of the underlying disk image.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - ISO: an archive format for the data contents of an optical disc, such as CD-ROM - QCOW2: a common disk image format, which can expand dynamically and supports copy on write - RAW: an unstructured disk image format - VDI: a common disk image format - VHD: a common disk image format - VHDX: enhanced version of VHD format - VMDK: a common disk image format\nNOTE: The list of permitted values was adapted from \"Disk formats\" in [i.5] (OpenStack® documentation: \"Disk and container formats for images\").\n",
							"description": "Disk format of a snapshot image is the format of the underlying disk image.\nPermitted values: - AKI: a kernel image format - AMI: a machine image format - ARI: a ramdisk image format - ISO: an archive format for the data contents of an optical disc, such as CD-ROM - QCOW2: a common disk image format, which can expand dynamically and supports copy on write - RAW: an unstructured disk image format - VDI: a common disk image format - VHD: a common disk image format - VHDX: enhanced version of VHD format - VMDK: a common disk image format\nSee note 2.\n",
							"type": "string",
						"enum": [
							"AKI",
							"AMI",
							"ARI",
							"ISO",
							"QCOW2",
							"RAW",
							"VDI",
							"VHD",
							"VHDX",
							"VMDK"
						]
							"enum": ["AKI", "AMI", "ARI", "ISO", "QCOW2", "RAW", "VDI", "VHD", "VHDX", "VMDK"]
						},
						"createdAt": {
							"description": "Date-time stamp. Representation: String formatted according to IETF RFC 3339.\n",
@@ -206,15 +158,12 @@
				}
			},
			"additionalArtifacts": {
			"description": "Information about VNF snapshot artifacts that are not VNFC snapshot images.\nNOTE: The attribute shall not be present before the VNF snapshot package content  has been uploaded or built. Otherwise, this attribute shall be present unless it  has been requested to be excluded per attribute selector.\n",
				"description": "Information about VNF snapshot artifacts that are not VNFC snapshot images.\nSee note.\n",
				"type": "object",
				"items": {
					"description": "This type represents an artifact other than a software image which is contained in  a VNF snapshot package.\n",
					"type": "object",
				"required": [
					"checksum",
					"isEncrypted"
				],
					"required": ["checksum", "isEncrypted"],
					"properties": {
						"artifactPath": {
							"description": "A string defined in IETF RFC 8259.\n",
@@ -240,17 +189,9 @@
				}
			},
			"state": {
			"description": "State of the VNF snapshot package.  Permitted values: - CREATED: the VNF snapshot package information has been created. - BUILDING: the VNF snapshot package is being built. - UPLOADING: the VNF snapshot package is being uploaded. - EXTRACTING: the VNF snapshot package’s content is being extracted. - AVAILABLE: the VNF snapshot package is available (i.e., build or upload is completed). - ERROR: failure during the VNF snapshot package building, uploading or processing. - ERROR_EXTRACTING: failure during the VNF snapshot package extraction task.\n",
				"description": "State of the VNF snapshot package.  Permitted values: - CREATED: the VNF snapshot package information has been created. - BUILDING: the VNF snapshot package is being built. - UPLOADING: the VNF snapshot package is being uploaded. - EXTRACTING: the VNF snapshot package’s content is being extracted. - AVAILABLE: the VNF snapshot package is available (i.e., build or upload is completed). - PROCESSING: the VNF snapshot is being processed.  - ERROR: failure during the VNF snapshot package building, uploading or processing. - ERROR_EXTRACTING: failure during the VNF snapshot package extraction task.\n",
				"type": "string",
			"enum": [
				"CREATED",
				"BUILDING",
				"UPLOADING",
				"EXTRACTING",
				"AVAILABLE",
				"ERROR",
				"ERROR_EXTRACTING"
			]
				"enum": ["CREATED", "BUILDING", "UPLOADING", "EXTRACTING", "AVAILABLE", "PROCESSING", "ERROR", "ERROR_EXTRACTING"]
			},
			"isCancelPending": {
				"description": "The Boolean is a data type having two values (true and false).\n",
@@ -259,32 +200,20 @@
			"failureDetails": {
				"description": "Failure details associated to current error state of the VNF snapshot package state. If \"state\" is \"ERROR\" or \"ERROR_EXTRACTING\", this attribute shall be present unless  it has been requested to be excluded via an attribute selector.\n",
				"type": "object",
			"required": [
				"errorType",
				"details"
			],
				"required": ["errorType", "details"],
				"properties": {
					"errorType": {
						"description": "Type of error, when the failure happened (building, upload, processing, extracting).\nPermitted values: - BUILD_ERROR - UPLOAD_ERROR - PROCESS_ERROR - CANCELLED - EXTRACTION_ERROR\n",
						"type": "string",
					"enum": [
						"BUILD_ERROR",
						"UPLOAD_ERROR",
						"PROCESS_ERROR",
						"CANCELLED",
						"EXTRACTION_ERROR"
					]
						"enum": ["BUILD_ERROR", "UPLOAD_ERROR", "PROCESS_ERROR", "CANCELLED", "EXTRACTION_ERROR"]
					},
					"details": {
					"description": "The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 [19] is reproduced inthis structure. Compared to the general framework defined in IETF RFC 7807 [19], the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 [19] foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807 [19].\n",
						"description": "The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 is reproduced inthis structure. Compared to the general framework defined in IETF RFC 7807, the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807.\n",
						"type": "object",
					"required": [
						"status",
						"detail"
					],
						"required": ["status", "detail"],
						"properties": {
							"type": {
							"description": "A URI reference according to IETF RFC 3986 [5] that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
								"description": "A URI reference according to IETF RFC 3986 that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
								"type": "string",
								"format": "URI"
							},
@@ -316,17 +245,12 @@
			"_links": {
				"description": "Links to resources related to this resource.\n",
				"type": "object",
			"required": [
				"self",
				"packageContent"
			],
				"required": ["self", "packageContent"],
				"properties": {
					"self": {
						"description": "This type represents a link to a resource using an absolute URI.\n",
						"type": "object",
					"required": [
						"href"
					],
						"required": ["href"],
						"properties": {
							"href": {
								"description": "String formatted according to IETF RFC 3986.\n",
@@ -337,9 +261,7 @@
					"packageContent": {
						"description": "This type represents a link to a resource using an absolute URI.\n",
						"type": "object",
					"required": [
						"href"
					],
						"required": ["href"],
						"properties": {
							"href": {
								"description": "String formatted according to IETF RFC 3986.\n",
+6 −6
Changes for SOL003/VNFSnapshotPackageManagement-API/IndividualVNFSnapshotPackage.robot: 6 added lines, 6 removed lines.
Original line number Diff line number Diff line
@@ -7,7 +7,7 @@ POST Individual VNF Snapshot Package - Method not implemented
    ...    Test title: POST Individual VNF Snapshot Package - Method not implemented
    ...    Test objective: The objective is to test that POST method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.3.3.1 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.3.3.1 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -19,7 +19,7 @@ GET Information about an individual VNF Snapshot Package - SUCCESSFUL
    ...    Test title: GET Information about an individual VNF Snapshot Package - SUCCESSFUL
    ...    Test objective: The objective is to query information about a VNF Snapshot Package resource
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.3.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.3.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -32,7 +32,7 @@ GET Information about an individual VNF Snapshot Package - NOT FOUND
    ...    Test title: GET Information about an individual VNF Snapshot Package - NOT FOUND
    ...    Test objective: The objective is to test that the retrieval of individual VNF Snapshot Package fails when using an invalid resource identifier.
    ...    Pre-conditions: At least one individual VNF Snapshot Package is available in the NFV-MANO.
    ...    Reference: Clause 12.4.3.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.3.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFV-MANO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -45,7 +45,7 @@ PUT Individual VNF Snapshot Package - Method not implemented
    ...    Test title: PUT Individual VNF Snapshot Package - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.3.3.3 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.3.3.3 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: VNF Snapshot Package not modified
@@ -57,7 +57,7 @@ PATCH Individual VNF Snapshot Package - Method Not implemented
    ...    Test title: PATCH Individual VNF Snapshot Package
    ...    Test objective: The objective is to test that PATCH method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.3.3.4 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.3.3.4 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: VNF Snapshot Package modified
@@ -69,7 +69,7 @@ DELETE Individual VNF Snapshot Package - Method Not implemented
    ...    Test title: DELETE Individual VNF Snapshot Package - Method Not implemented
    ...    Test objective: The objective is to test that DELETE method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.3.3.5 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.3.3.5 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: VNF Snapshot Package deleted
+9 −9
Changes for SOL003/VNFSnapshotPackageManagement-API/IndividualVNFSnapshotPackageArtifact.robot: 9 added lines, 9 removed lines.
Original line number Diff line number Diff line
@@ -7,7 +7,7 @@ POST Individual VNF Snapshot Package Artifact - Method not implemented
    ...    Test title: POST Individual VNF Snapshot Package Artifact - Method not implemented
    ...    Test objective: The objective is to test that POST method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.1 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.1 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO 
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -19,7 +19,7 @@ GET Individual VNF Snapshot Package Artifact - Complete File
    ...    Test title: GET Information about an individual VNF Snapshot Package - Complete File
    ...    Test objective: The objective is to fetch the whole content of a VNF snapshot package using GET method.
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -32,7 +32,7 @@ GET Individual VNF Snapshot Package Artifact - Partial Content
    ...    Test title: GET Individual VNF Snapshot Package Artifact - Partial Content
    ...    Test objective: The objective is to fetch partial content of a VNF snapshot package by sending a range request using GET method.
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: NFVO supports range requests
    ...    Post-Conditions: none
@@ -47,7 +47,7 @@ GET Individual VNF Snapshot Package Artifact - Range Request Not Supported
    ...    Test title: GET Information about an individual VNF Snapshot Package - Range Request Not Supported
    ...    Test objective: The objective is to test that the whole content of a VNF snapshot package is delivered even with a range request when NFVO does not support range requests.
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: NFVO does not support range requests
    ...    Post-Conditions: none
@@ -60,7 +60,7 @@ GET Individual VNF Snapshot Package Artifact - Range Not Satisfiable
    ...    Test title: GET Information about an individual VNF Snapshot Package - Range Not Satisfiable
    ...    Test objective: The objective is to test that an error is returned when the byte range passed in the "Range" header does not match any available byte range in the VNF snapshot package file.
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: NFVO supports range requests
    ...    Post-Conditions: none
@@ -72,7 +72,7 @@ GET Individual VNF Snapshot Package Artifact - Conflict
    ...    Test title: GET Information about an individual VNF Snapshot Package - Conflict
    ...    Test objective: The objective is to test that an error is returned when the "state" of the VNF snapshot package has a value different from "AVAILABLE".
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.2 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: The "state" of the VNF snapshot package has a value different from "AVAILABLE".
    ...    Post-Conditions: none
@@ -84,7 +84,7 @@ PUT Individual VNF Snapshot Package Artifact - Method not implemented
    ...    Test title: PUT Individual VNF Snapshot Package Artifact - Method not implemented
    ...    Test objective: The objective is to test that PUT method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.3 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.3 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: VNF Snapshot Package not modified
@@ -96,7 +96,7 @@ PATCH Individual VNF Snapshot Package Artifact - Method Not implemented
    ...    Test title: PATCH Individual VNF Snapshot Package Artifact
    ...    Test objective: The objective is to test that PATCH method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.4 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.4 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
@@ -108,7 +108,7 @@ DELETE Individual VNF Snapshot Package Artifact - Method Not implemented
    ...    Test title: DELETE Individual VNF Snapshot Package Artifact - Method Not implemented
    ...    Test objective: The objective is to test that DELETE method is not implemented
    ...    Pre-conditions: none
    ...    Reference: Clause 12.4.5.3.5 - ETSI GS NFV-SOL 003 [1] v3.3.1
    ...    Reference: Clause 12.4.5.3.5 - ETSI GS NFV-SOL 003 [1] v3.5.1
    ...    Config ID: Config_prod_NFVO
    ...    Applicability: none
    ...    Post-Conditions: none
Loading
Loading