Changes for SOL002/VNFConfiguration-API/schemas/vnfConfigModifications.schema.json: 78 added lines, 6 removed lines.
Original line number
Diff line number
Diff line
{
"description":"This type represents request parameters for the \"Set Configuration\" operation. * NOTE 1: At least one of \"vnfConfigurationData\" and \"vnfcConfigurationData\"\n shall be present.\n * NOTE 2: The VnfcConfiguration data type can only be used to modify the configuration\n of existing VNFC instances.\n",
"description":"This type represents request parameters for the \"Set Configuration\" operation.\n * NOTE 1: At least one of \"vnfConfigurationData\" and \"vnfcConfigurationData\"\n shall be present.\n * NOTE 2: The VnfcConfiguration data type can only be used to modify the configuration\n of existing VNFC instances.\n",
"type":"object",
"anyOf":[
{
"required":[
"vnfConfigurationData"
]
},
{
"required":[
"vnfcConfigurationData"
]
}
],
"properties":{
"vnfConfigurationData":{
"description":"This type represents configuration parameters of a VNF instance.\n",
"type":"object",
"properties":{
"extCpConfig":{
"description":"Configuration parameters for the external CPs of the VNF instance.\n",
"type":"array",
"items":{
"description":"This type represents configuration parameters of a CP instance.\n",
"type":"object",
"required":[
@@ -27,8 +42,32 @@
"description":"Network address and port assigned to the CP.\n",
"type":"array",
"items":{
"description":"This type represents configuration parameters of a CP instance address. * NOTE 1: Either \"address\" or \"useDynamicAddress\" shall be present.\n * NOTE 2: At least one of \"macAddress\" and \"ipAddress\" shall be present.\n",
"description":"This type represents configuration parameters of a CP instance address.\n * NOTE 1: Either \"address\" or \"useDynamicAddress\" shall be present.\n * NOTE 2: At least one of \"macAddress\" and \"ipAddress\" shall be present.\n",
"type":"object",
"oneOf":[
{
"required":[
"address"
]
},
{
"required":[
"useDynamicAddress"
]
}
],
"anyOf":[
{
"required":[
"macAddress"
]
},
{
"required":[
"ipAddress"
]
}
],
"properties":{
"address":{
"description":"Network address that has been configured on the CP. See NOTE 1.\n",
@@ -58,6 +97,7 @@
}
}
}
}
},
"dhcpServer":{
"description":"An IPV4 or IPV6 address. Representation: In case of an IPV4 address, string that consists of four decimal integers separated by dots, each integer ranging from 0 to 255. In case of an IPV6 address, string that consists of groups of zero to four hexadecimal digits, separated by colons.\n",
@@ -65,13 +105,13 @@
"format":"IP"
},
"vnfSpecificData":{
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159.\n",
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of keyvalue pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 8259. In the following example, a list of key-value pairs with four keys (\"aString\", \"aNumber\", \"anArray\" and \"anObject\") is provided to illustrate that the values associated with different keys can be of different type.\n",
"type":"object"
}
}
},
"vnfcConfigurationData":{
"description":"Modifications to configuration data for certain VNFC instances. See NOTE 1 and NOTE 2. If present, the modifications of the \"vnfcConfigurationData\" attribute shall follow these provisions: Modifying an attribute that is an array of objects of type \"VnfcConfigurationData\".\n Assumptions:\n1) \"oldList\" is the \"VnfcConfigurationData\" array to be modified and \"newList\"\nis the \"VnfcConfigurationData\" array that contains the changes.\n2) \"oldEntry\" is an entry in \"oldList\" and \"newEntry\" is an entry in \"newList\".\n3) A \"newEntry\" has a \"corresponding entry\" if there exists an \"oldEntry\" that\nhas the same content of the \"vnfcInstanceId\" attribute as the \"newEntry\";\na \"newEntry\" has no corresponding entry if no such \"oldEntry\" exists.\n4) In any array of \"VnfcConfigurationData\" structures, the content of \"vnfcInstanceId\"\nis unique (i.e. there shall be no two entries with the same content of \"vnfcInstanceId\").\n Provisions:\n1) For each \"newEntry\" in \"newList\" that has no corresponding entry in \"oldList\",\nthe \"oldList\" array shall be modified by adding that \"newEntry\".\n\n2) For each \"newEntry\" in \"newList\" that has a corresponding \"oldEntry\" in \"oldList\",\nthe value of \"oldEntry\" shall be updated with the value of \"newEntry\" according to\nthe rules of JSON Merge PATCH (see IETF RFC 7396 ).\n",
"description":"Modifications to configuration data for certain VNFC instances. See NOTE 1 and NOTE 2. If present, the modifications of the \"vnfcConfigurationData\" attribute shall follow these provisions:\n Modifying an attribute that is an array of objects of type \"VnfcConfigurationData\".\n Assumptions:\n 1) \"oldList\" is the \"VnfcConfigurationData\" array to be modified and \"newList\"\n is the \"VnfcConfigurationData\" array that contains the changes.\n 2) \"oldEntry\" is an entry in \"oldList\" and \"newEntry\" is an entry in \"newList\".\n 3) A \"newEntry\" has a \"corresponding entry\" if there exists an \"oldEntry\" that\n has the same content of the \"vnfcInstanceId\" attribute as the \"newEntry\";\n a \"newEntry\" has no corresponding entry if no such \"oldEntry\" exists.\n 4) In any array of \"VnfcConfigurationData\" structures, the content of \"vnfcInstanceId\"\n is unique (i.e. there shall be no two entries with the same content of \"vnfcInstanceId\").\n Provisions:\n 1) For each \"newEntry\" in \"newList\" that has no corresponding entry in \"oldList\",\n the \"oldList\" array shall be modified by adding that \"newEntry\".\n\n 2) For each \"newEntry\" in \"newList\" that has a corresponding \"oldEntry\" in \"oldList\",\n the value of \"oldEntry\" shall be updated with the value of \"newEntry\" according to\n the rules of JSON Merge PATCH (see IETF RFC 7396 ).\n",
"type":"array",
"items":{
"description":"This type represents configuration parameters of a VNFC instance.\n",
@@ -108,8 +148,32 @@
"description":"Network address and port assigned to the CP.\n",
"type":"array",
"items":{
"description":"This type represents configuration parameters of a CP instance address. * NOTE 1: Either \"address\" or \"useDynamicAddress\" shall be present.\n * NOTE 2: At least one of \"macAddress\" and \"ipAddress\" shall be present.\n",
"description":"This type represents configuration parameters of a CP instance address.\n * NOTE 1: Either \"address\" or \"useDynamicAddress\" shall be present.\n * NOTE 2: At least one of \"macAddress\" and \"ipAddress\" shall be present.\n",
"type":"object",
"oneOf":[
{
"required":[
"address"
]
},
{
"required":[
"useDynamicAddress"
]
}
],
"anyOf":[
{
"required":[
"macAddress"
]
},
{
"required":[
"ipAddress"
]
}
],
"properties":{
"address":{
"description":"Network address that has been configured on the CP. See NOTE 1.\n",
@@ -147,11 +211,19 @@
"format":"IP"
},
"vnfcSpecificData":{
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159.\n",
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of keyvalue pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 8259. In the following example, a list of key-value pairs with four keys (\"aString\", \"aNumber\", \"anArray\" and \"anObject\") is provided to illustrate that the values associated with different keys can be of different type.\n",
"type":"object"
}
}
}
},
"vnfcConfigurationDataDeleteIds":{
"description":"List of identifiers entries to be deleted from the 'vnfcConfigurationData\" attribute array to be used as \"deleteIdList\" as defined below this table.\n",
"type":"array",
"items":{
"description":"An identifier with the intention of being globally unique.\n",
Changes for SOL002/VNFConfiguration-API/Configuration.robot: 25 added lines, 29 removed lines.
Original line number
Diff line number
Diff line
@@ -12,7 +12,7 @@ Set new VNF Configuration
...Test title: Set a new VNF Configuration
...Test objective: The objective is to test the creation of a new VNF configuration and perform a JSON schema validation of the returned configuration data structure
...Pre-conditions: A VNF instance is instantiated
...Reference: Clause 9.4.2.3.4 - ETSI GS NFV-SOL 002 [2] v2.6.1
...Reference: Clause 9.4.2.3.4 - ETSI GS NFV-SOL 002 [2] v3.3.1
...Config ID: Config_prod_VE
...Applicability: The VNF supports the generation of HTTP Etag opaque identifiers
...Post-Conditions: The configuration is successfully set in the VNF and it matches the issued configuration
@@ -28,7 +28,7 @@ Get information about a VNF configuration
...Test title: Get information about a VNF configuration
...Test objective: The objective is to test the retrieval of an existing VNF instance configuration and perform a JSON schema validation of the collected configuration data structure
...Pre-conditions: A VNF instance is instantiated. The VNF instance is already configured.
...Reference: Clause 9.4.2.3.2 - ETSI GS NFV-SOL 002 [2] v2.6.1
...Reference: Clause 9.4.2.3.2 - ETSI GS NFV-SOL 002 [2] v3.3.1
...Config ID: Config_prod_VE
...Applicability: none
...Post-Conditions: none
@@ -42,7 +42,7 @@ Get information about a VNF configuration with HTTP Etag
...Test title: Get information about a VNF configuration with HTTP Etag
...Test objective: The objective is to test the retrieval of an existing VNF instance configuration, check the generation by the VNF of an HTTP Etag opaque identifier, and perform a JSON schema validation of the collected configuration data structure
...Pre-conditions:A VNF instance is instantiated. The VNF instance is already configured
...Reference: Clause 9.4.2.3.2 - ETSI GS NFV-SOL 002 [2] v2.6.1
...Reference: Clause 9.4.2.3.2 - ETSI GS NFV-SOL 002 [2] v3.3.1
...Config ID: Config_prod_VE
...Applicability: The VNF supports the generation of HTTP Etag opaque identifiers
...Post-Conditions: none
@@ -57,7 +57,7 @@ Set new VNF Configuration - HTTP Etag precondition unsuccessful
...Test title: Set a new VNF Configuration - HTTP Etag precondition unsuccessful
...Test objective: The objective is to test the unsuccess in setting a duplication of VNF configuration identified by an already used HTTP Etag identifier. The test also checks the JSON schema of the unsuccessful operation HTTP response.
...Pre-conditions:A VNF instance is instantiated. The VNF instance is already configured (Test ID 6.3.1.1.1) with a given HTTP Etag identifier.
...Reference: Clause 9.4.2.3.4 - ETSI GS NFV-SOL 002 [2] v2.6.1
...Reference: Clause 9.4.2.3.4 - ETSI GS NFV-SOL 002 [2] v3.3.1
...Config ID: Config_prod_VE
...Applicability: The VNF supports the generation of HTTP Etag opaque identifiers
...Post-Conditions:The VNF configuration is not modified by the unsuccessful operation and it matches the configuration issued in Test ID 6.3.1.1.1
@@ -70,8 +70,8 @@ POST VNF Configuration - Method not implemented
[Documentation]Test ID: 6.3.1.1.5
...Test title: POST VNF Configuration - Method not implemented
...Test objective: The objective is to test that POST method is not allowed to create a new VNF configuration
...Pre-conditions: A VNF instance is instantiated. The VNF instance is alrseady configured
...Reference: Clause 9.4.2.3.1 - ETSI GS NFV-SOL 002 [2] v2.6.1
...Pre-conditions: none
...Reference: Clause 9.4.2.3.1 - ETSI GS NFV-SOL 002 [2] v3.3.1
...Config ID: Config_prod_VE
...Applicability: none
...Post-Conditions: none
@@ -82,8 +82,8 @@ PUT VNF Configuration - Method not implemented
[Documentation]Test ID: 6.3.1.1.6
...Test title: PUT VNF Configuration - Method not implemented
...Test objective: The objective is to test that PUT method is not allowed to modify an existing VNF configuration
...Pre-conditions:A VNF instance is instantiated. The VNF instance is already configured
...Reference: Clause 9.4.2.3.3 - ETSI GS NFV-SOL 002 [2] v2.6.1
...Pre-conditions:none
...Reference: Clause 9.4.2.3.3 - ETSI GS NFV-SOL 002 [2] v3.3.1