Changes for SOL005/NSDManagement-API/schemas/NsdChangeNotification.schema.json: 86 added lines, 0 removed lines.
Original line number
Diff line number
Diff line
{
"type":"object",
"required":[
"_links",
"id",
"notificationType",
"nsdId",
"nsdInfoId",
"nsdOperationalState",
"timeStamp"
],
"properties":{
"id":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"notificationType":{
"type":"string",
"description":"\"Discriminator for the different notification types. Shall be set to \"NsdChangeNotification\" for this notification type.\"\n"
},
"subscriptionId":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"timeStamp":{
"description":"Date-time stamp. Representation: String formatted according to IETF RFC 3339.\n",
"type":"string",
"format":"date-time"
},
"nsdInfoId":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"nsdId":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"nsdOperationalState":{
"type":"string",
"description":"\"The enumeration NsdOperationalStateType shall comply with the provisions defined in Table 5.5.4.3-1 of GS NFV_SOL 005. It indicates the operational state of the resource. ENABLED = The operational state of the resource is enabled. DISABLED = The operational state of the resource is disabled.\"\n",
"enum":[
"ENABLED",
"DISABLED"
]
},
"_links":{
"type":"object",
"required":[
"nsdInfo",
"subscription"
],
"properties":{
"nsdInfo":{
"description":"This type represents a link to a resource.\n",
"type":"object",
"required":[
"href"
],
"properties":{
"href":{
"description":"URI of the referenced resource.\n",
"type":"string",
"format":"url"
}
}
},
"subscription":{
"description":"This type represents a link to a resource.\n",
"type":"object",
"required":[
"href"
],
"properties":{
"href":{
"description":"URI of the referenced resource.\n",
"type":"string",
"format":"url"
}
}
}
},
"description":"\"This type represents the links to resources that an NSD management notification can contain.\"\n"
}
},
"description":"\"This type represents an NSD management notification, which informs the receiver of a change of the \"nsdOperationalState\" attribute of an on-boarded NSD. Changes in the value of the \"nsdUsageState\" and \"nsdOnboardingState\" attributes are not reported. The notification shall comply with the provisions defined in Table 5.5.2.11-1. The support of this notification is mandatory. The notification shall be triggered by the NFVO when the value of the \"nsdOperationalState\" attribute has changed, and the \"nsdOperationalState\" attribute has the value \"ONBOARDED\".\""
Changes for SOL005/NSDManagement-API/schemas/NsdDeletionNotification.schema.json: 77 added lines, 0 removed lines.
Original line number
Diff line number
Diff line
{
"type":"object",
"required":[
"_links",
"id",
"notificationType",
"nsdId",
"nsdInfoId",
"timeStamp"
],
"properties":{
"id":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"notificationType":{
"type":"string",
"description":"\"Discriminator for the different notification types. Shall be set to \"NsdDeletionNotification \" for this notification type.\"\n"
},
"subscriptionId":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"timeStamp":{
"description":"Date-time stamp. Representation: String formatted according to IETF RFC 3339.\n",
"type":"string",
"format":"date-time"
},
"nsdInfoId":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"nsdId":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"_links":{
"type":"object",
"required":[
"nsdInfo",
"subscription"
],
"properties":{
"nsdInfo":{
"description":"This type represents a link to a resource.\n",
"type":"object",
"required":[
"href"
],
"properties":{
"href":{
"description":"URI of the referenced resource.\n",
"type":"string",
"format":"url"
}
}
},
"subscription":{
"description":"This type represents a link to a resource.\n",
"type":"object",
"required":[
"href"
],
"properties":{
"href":{
"description":"URI of the referenced resource.\n",
"type":"string",
"format":"url"
}
}
}
},
"description":"\"This type represents the links to resources that an NSD management notification can contain.\"\n"
}
},
"description":"\"This type represents an NSD management notification, which informs the receiver of the deletion of an on-boarded NSD. The notification shall comply with the provisions defined in Table 5.5.2.12-1. The support of this notification is mandatory. The notification shall be triggered by the NFVO when it has deleted an on-boarded NSD.\""
Changes for SOL005/NSDManagement-API/schemas/NsdInfo.schema.json: 100 added lines, 24 removed lines.
Original line number
Diff line number
Diff line
{
"type":"object",
"required":[
"_links",
"id",
"nsdOnboardingState",
"nsdOperationalState",
"nsdUsageState"
"nsdUsageState",
"_links"
],
"properties":{
"id":{
"type":"string",
"description":"Identifier of the onboarded individual NS descriptor resource. This identifier is allocated by the NFVO."
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"nsdId":{
"type":"object",
"description":"This identifier, which is allocated by the NSD designer, identifies the NSD in a globally unique way. It is copied from the NSD content and shall be present after the NSD content is on-boarded."
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"nsdName":{
"type":"string",
"description":"Name of the onboarded NSD. This information is copied from the NSD content and shall be present after the NSD content is on-boarded."
"description":"\"Name of the onboarded NSD. This information is copied from the NSD content and shall be present after the NSD content is on-boarded.\"\n"
},
"nsdVersion":{
"type":"string",
"description":"Version of the on-boarded NSD. The NSD version is a string of variable length.This information is copied from the NSD content and shall be present after the NSD content is on-boarded."
"description":"A Version.\n",
"type":"string"
},
"nsdDesigner":{
"type":"string",
"description":"Designer of the on-boarded NSD. This information \nis copied from the NSD content and shall be present after the NSD content is on-boarded."
"description":"\"Designer of the on-boarded NSD. This information is copied from the NSD content and shall be present after the NSD content is on-boarded.\"\n"
},
"nsdInvariantId":{
"type":"string",
"description":"This identifier, which is allocated by the NSD designer, identifies an NSD in a version independent manner. This information is copied from the NSD content and shall be present after the NSD content is on-boarded."
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
},
"vnfPkgIds":{
"description":"Identifies the VNF package for the VNFD referenced by the on-boarded NS descriptor resource.\n",
"type":"array",
"description":"Identifies the VNF package for the VNFD referenced by the on-boarded NS descriptor resource.",
"items":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
}
},
"pnfdInfoIds":{
"description":"Identifies the PnfdInfo element for the PNFD referenced by the on-boarded NS descriptor resource.\n",
"type":"array",
"description":"Identifies the PnfdInfo element for the PNFD referenced by the on-boarded NS descriptor resource.",
"items":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
}
},
"nestedNsdInfoIds":{
"description":"Identifies the NsdInfo element for the nested NSD referenced by the on-boarded NS descriptor resource.\n",
"type":"array",
"description":"Identifies the NsdInfo element for the nested NSD referenced by the on-boarded NS descriptor resource. At least one of the attributes – vnfPkgId and nestedNsdInfoId shall be present, after the NSD is on-boarded.",
"items":{
"description":"An identifier with the intention of being globally unique.\n",
"type":"string"
}
},
"nsdOnboardingState":{
"$ref":"#/definitions/NsdOnboardingStateType"
"type":"string",
"description":"\"The enumeration NsdOnboardingStateType shall comply with the provisions defined in Table 5.5.4.5-1 of GS NFV-SOL 005. It indicates the on-boarding state of the NSD. CREATED = The NSD information object is created. UPLOADING = The associated NSD content is being uploaded. PROCESSING = The associated NSD content is being processed, e.g. validation. ONBOARDED = The associated NSD content is on-boarded.\"\n",
"enum":[
"CREATED",
"UPLOADING",
"PROCESSING",
"ONBOARDED"
]
},
"onboardingFailureDetails":{
"$ref":"#/definitions/ProblemDetails"
"description":"The definition of the general \"ProblemDetails\" data structure from IETF RFC 7807 [19] is reproduced in this structure. Compared to the general framework defined in IETF RFC 7807 [19], the \"status\" and \"detail\" attributes are mandated to be included by the present document, to ensure that the response contains additional textual information about an error. IETF RFC 7807 [19] foresees extensibility of the \"ProblemDetails\" type. It is possible that particular APIs in the present document, or particular implementations, define extensions to define additional attributes that provide more information about the error. The description column only provides some explanation of the meaning to Facilitate understanding of the design. For a full description, see IETF RFC 7807 [19].\n",
"type":"object",
"required":[
"statussss",
"detail"
],
"properties":{
"type":{
"description":"A URI reference according to IETF RFC 3986 [5] that identifies the problem type. It is encouraged that the URI provides human-readable documentation for the problem (e.g. using HTML) when dereferenced. When this member is not present, its value is assumed to be \"about:blank\".\n",
"type":"string",
"format":"URI"
},
"title":{
"description":"A short, human-readable summary of the problem type. It should not change from occurrence to occurrence of the problem, except for purposes of localization. If type is given and other than \"about:blank\", this attribute shall also be provided. A short, human-readable summary of the problem type. It SHOULD NOT change from occurrence to occurrence of the problem, except for purposes of localization (e.g., using proactive content negotiation; see [RFC7231], Section 3.4).\n",
"type":"string"
},
"status":{
"description":"The HTTP status code for this occurrence of the problem. The HTTP status code ([RFC7231], Section 6) generated by the origin server for this occurrence of the problem.\n",
"type":"integer"
},
"detail":{
"description":"A human-readable explanation specific to this occurrence of the problem.\n",
"type":"string"
},
"instance":{
"description":"A URI reference that identifies the specific occurrence of the problem. It may yield further information if dereferenced.\n",
"type":"string",
"format":"URI"
}
}
},
"nsdOperationalState":{
"$ref":"#/definitions/NsdOperationalStateType"
"type":"string",
"description":"\"The enumeration NsdOperationalStateType shall comply with the provisions defined in Table 5.5.4.3-1 of GS NFV_SOL 005. It indicates the operational state of the resource. ENABLED = The operational state of the resource is enabled. DISABLED = The operational state of the resource is disabled.\"\n",
"enum":[
"ENABLED",
"DISABLED"
]
},
"nsdUsageState":{
"$ref":"#/definitions/NsdUsageStateType"
"type":"string",
"description":"\"The enumeration NsdUsageStateType shall comply with the provisions defined in Table 5.5.4.4-1 of GS NFV-SOL 005. It indicates the usage state of the resource.IN_USE = The resource is in use.NOT_IN_USE = The resource is not-in-use.\"\n",
"enum":[
"IN_USE",
"NOT_IN_USE"
]
},
"userDefinedData":{
"$ref":"#/definitions/KeyValuePairs"
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159. \n",
"type":"object"
},
"_links":{
"type":"object",
"description":"Links to resources related to this resource.",
"required":[
"self",
"nsd_content"
],
"description":"\"Links to resources related to this resource.\"\n",
"properties":{
"self":{
"$ref":"#/definitions/Link"
"description":"This type represents a link to a resource.\n",
"type":"object",
"required":[
"href"
],
"properties":{
"href":{
"description":"URI of the referenced resource.\n",
"type":"string",
"format":"url"
}
}
},
"nsd_content":{
"$ref":"#/definitions/Link"
"description":"This type represents a link to a resource.\n",
"type":"object",
"required":[
"href"
],
"properties":{
"href":{
"description":"URI of the referenced resource.\n",
"type":"string",
"format":"url"
}
}
}
}
}
},
"description":"This type represents a response for the query NSD operation. It shall comply with the provisions defined in\nTable 5.5.2.2-1 of GS NFV-SOL 005."
"description":"\"This type represents a response for the query NSD operation.\"\t\n"
Changes for SOL005/NSDManagement-API/schemas/NsdInfoModification.schema.json: 14 added lines, 5 removed lines.
Original line number
Diff line number
Diff line
{
"type":"object",
"description":"This type represents attribute modifications for an individual NS descriptor resource based on the NsdInfo data type. The attributes of NsdInfo that can be modified are included in the NsdInfoModifications data type.NOTE: At least one of the attributes - nsdOperationalState and userDefinedData - shall be present.\n",
"properties":{
"nsdOperationalState":{
"$ref":"#/definitions/NsdOperationalStateType"
"type":"string",
"description":"\"The enumeration NsdOperationalStateType shall comply with the provisions defined in Table 5.5.4.3-1 of GS NFV_SOL 005. It indicates the operational state of the resource. ENABLED = The operational state of the resource is enabled. DISABLED = The operational state of the resource is disabled.\"\n",
"enum":[
"ENABLED",
"DISABLED"
]
},
"userDefinedData":{
"type":"object",
"description":"Modifications of the \"userDefinedData\" attribute in \"NsdInfo\" data type. See note. If present, these modifications shall be applied according to the rules of JSON Merge PATCH (see IETF RFC 7396 [25]). NOTE: At least one of the attributes - nsdOperationalState and userDefinedData - shall be present."
"description":"Modifications of the userDefinedData attribute in NsdInfo data type. See note. If present, these modifications shall be applied according to the rules of JSON Merge PATCH (see IETF RFC 7396 [25]). NOTE- At least one of the attributes - nsdOperationalState and userDefinedData - shall be present.\n",
"type":"array",
"items":{
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159. \n",
"type":"object"
}
}
}
},
"description":"This type represents attribute modifications for an individual NS descriptor resource based on the \"NsdInfo\" data type. The attributes of \"NsdInfo\" that can be modified are included in the \"NsdInfoModifications\" data type.\n\nNOTE: At least one of the attributes - nsdOperationalState and userDefinedData - shall be present."
Changes for SOL005/NSDManagement-API/schemas/NsdInfoModifications.schema.json: 25 added lines, 0 removed lines.
Original line number
Diff line number
Diff line
{
"type":"array",
"items":{
"type":"object",
"description":"This type represents attribute modifications for an individual NS descriptor resource based on the NsdInfo data type. The attributes of NsdInfo that can be modified are included in the NsdInfoModifications data type.NOTE: At least one of the attributes - nsdOperationalState and userDefinedData - shall be present.\n",
"properties":{
"nsdOperationalState":{
"type":"string",
"description":"\"The enumeration NsdOperationalStateType shall comply with the provisions defined in Table 5.5.4.3-1 of GS NFV_SOL 005. It indicates the operational state of the resource. ENABLED = The operational state of the resource is enabled. DISABLED = The operational state of the resource is disabled.\"\n",
"enum":[
"ENABLED",
"DISABLED"
]
},
"userDefinedData":{
"description":"Modifications of the userDefinedData attribute in NsdInfo data type. See note. If present, these modifications shall be applied according to the rules of JSON Merge PATCH (see IETF RFC 7396 [25]). NOTE- At least one of the attributes - nsdOperationalState and userDefinedData - shall be present.\n",
"type":"array",
"items":{
"description":"This type represents a list of key-value pairs. The order of the pairs in the list is not significant. In JSON, a set of key- value pairs is represented as an object. It shall comply with the provisions defined in clause 4 of IETF RFC 7159. \n",