Loading src/SOL005/APIVersion/APIVersion.yaml +2 −2 Viewed Changes for src/SOL005/APIVersion/APIVersion.yaml: 2 added lines, 2 removed lines. Original line number Diff line number Diff line Loading @@ -19,8 +19,8 @@ info: version: 1.0.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_nfv-sol005v030701p.pdf servers: - url: http://127.0.0.1/ Loading src/SOL005/NFVICapacityInformation/definitions/NFVICapacityInformation_def.yaml +1 −1 Viewed Changes for src/SOL005/NFVICapacityInformation/definitions/NFVICapacityInformation_def.yaml: 1 added line, 1 removed line. Original line number Diff line number Diff line Loading @@ -227,7 +227,7 @@ components: type: object description: | This type defines the format of a time interval. The type shall comply with the provisions defined in table 10.5.2.7-1. NOTE: When only the startTime is present, there is no time interval being defined, and therefore the provided timing NOTE: When only the aTime is present, there is no time interval being defined, and therefore the provided timing information refers to a specific point in time. required: - aTime Loading src/SOL005/NFVICapacityInformation/NFVICapacityInformation.yaml +45 −11 Viewed Changes for src/SOL005/NFVICapacityInformation/NFVICapacityInformation.yaml: 45 added lines, 11 removed lines. Original line number Diff line number Diff line Loading @@ -16,11 +16,11 @@ info: license: name: ETSI Forge copyright notice url: https://forge.etsi.org/etsi-forge-copyright-notice.txt version: 1.0.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 version: 1.1.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_NFV-SOL005v030701p.pdf servers: - url: http://127.0.0.1/nfvici/v1 Loading Loading @@ -315,7 +315,7 @@ components: description: | Identifier of the VIM with associated NFVI capacity information. This identifier can be retrieved from the "vimId" attribute in the CapacityShortageNotification. It can also be retrieved from the "vimId" attribute in the payload body of the response. It can also be retrieved from the "vimId" attribute in the message content of the response. required: true style: simple explode: false Loading @@ -329,7 +329,7 @@ components: Identifier of the capacity threshold. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new "Individual capacity threshold" resource. It can also be retrieved from the "id" attribute in the payload body of that response. attribute in the message content of that response. required: true style: simple explode: false Loading Loading @@ -498,11 +498,11 @@ components: CapacityThresholds.Post.422: description: | 422 UNPROCESSABLE ENTITY 422 Unprocessable Content Shall be returned upon the following error: The content type of the payload body is supported and the payload body of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013 [16], Shall be returned upon the following error: The content type of the message content is supported and the message content of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013, including rules for the presence of the response body. Specifically in case of this resource, the response code 422 shall also be returned if the NFVO has tested the Notification endpoint as described in clause 10.4.6.3.2 and the test has failed. Loading Loading @@ -592,6 +592,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string content: application/json: schema: Loading Loading @@ -630,9 +664,9 @@ components: IndividualCapacityThreshold.Patch.422: description: | 422 UNPROCESSABLE ENTITY 422 Unprocessable Content content type of the payload body is supported and the payload body of a request contains syntactically The content type of the message content is supported and the message content of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013 [16], including rules for the presence of the response body. Loading src/SOL005/NFVICapacityInformationNotification/NFVICapacityInformationNotification.yaml +3 −3 Viewed Changes for src/SOL005/NFVICapacityInformationNotification/NFVICapacityInformationNotification.yaml: 3 added lines, 3 removed lines. Original line number Diff line number Diff line Loading @@ -16,11 +16,11 @@ info: license: name: ETSI Forge copyright notice url: https://forge.etsi.org/etsi-forge-copyright-notice.txt version: 1.0.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 version: 1.1.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_NFV-SOL005v030701p.pdf servers: - url: http://127.0.0.1/callback/v1 Loading src/SOL005/NSDManagement/NSDManagement.yaml +225 −81 Viewed Changes for src/SOL005/NSDManagement/NSDManagement.yaml: 225 added lines, 81 removed lines. Original line number Diff line number Diff line Loading @@ -16,11 +16,11 @@ info: license: name: ETSI Forge copyright notice url: https://forge.etsi.org/etsi-forge-copyright-notice.txt version: 2.2.1-impl:etsi.org:ETSI_NFV_OpenAPI:1 version: 2.3.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_NFV-SOL005v030701p.pdf servers: - url: http://127.0.0.1/nsd/v2 Loading @@ -37,7 +37,7 @@ paths: # NS Descriptors # ############################################################################### /ns_descriptors: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.2 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.2 parameters: - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization - $ref: ../components/SOL005_params.yaml#/components/parameters/Version Loading Loading @@ -128,7 +128,7 @@ paths: # Individual NS Descriptor # ############################################################################### /ns_descriptors/{nsdInfoId}: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.3 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.3 parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -224,7 +224,7 @@ paths: # NSD Archive Content # ############################################################################### /ns_descriptors/{nsdInfoId}/nsd_content: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.4 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4 parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -297,7 +297,7 @@ paths: # NSD # ############################################################################### /ns_descriptors/{nsdInfoId}/nsd: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.4a #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4a parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -337,7 +337,7 @@ paths: # NSD Archive Manifest # ############################################################################### /ns_descriptors/{nsdInfoId}/manifest: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.4b #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4b parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -387,7 +387,7 @@ paths: # Individual NSD Archive Artifact # ############################################################################### /ns_descriptors/{nsdInfoId}/artifacts/{artifactPath}: #ETSI GS NFV-SOL 005 V3.5.1 location: 5.4.4c #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4c parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: '#/components/parameters/ArtifactPathInNSD' Loading Loading @@ -439,7 +439,7 @@ paths: # PNF Descriptors # ############################################################################### /pnf_descriptors: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.5 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.5 parameters: - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization - $ref: ../components/SOL005_params.yaml#/components/parameters/Version Loading Loading @@ -530,7 +530,7 @@ paths: # Individual PNF Descriptor # ############################################################################### /pnf_descriptors/{pnfdInfoId}: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.6 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.6 parameters: - $ref: '#/components/parameters/PnfdInfoId' Loading Loading @@ -624,7 +624,7 @@ paths: # PNFD Archive Content # ############################################################################### /pnf_descriptors/{pnfdInfoId}/pnfd_content: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.7 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7 parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -698,7 +698,7 @@ paths: # PNFD # ############################################################################### /pnf_descriptors/{pnfdInfoId}/pnfd: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.7a #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7a parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -739,7 +739,7 @@ paths: # PNFD Archive Manifest # ############################################################################### /pnf_descriptors/{pnfdInfoId}/manifest: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.7b #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7b parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -791,7 +791,7 @@ paths: # Individual PNFD Archive Artifact # ############################################################################### /pnf_descriptors/{pnfdInfoId}/artifacts/{artifactPath}: #ETSI GS NFV-SOL 005 V3.5.1 location: 5.4.7c #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7c parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: '#/components/parameters/ArtifactPathInPNFD' Loading Loading @@ -842,7 +842,7 @@ paths: # Subscriptions # ############################################################################### /subscriptions: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.8 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.8 parameters: - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization - $ref: ../components/SOL005_params.yaml#/components/parameters/Version Loading Loading @@ -924,7 +924,7 @@ paths: # Individual Subscription # ############################################################################### /subscriptions/{subscriptionId}: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.9 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.9 parameters: - $ref: '#/components/parameters/SubscriptionId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -1039,7 +1039,7 @@ components: ContentTypeZip: name: Content-Type description: | The payload body contains a ZIP file that represents the NSD archive, as specified above. The message content contains a ZIP file that represents the NSD archive, as specified above. The request shall set the "Content-Type" HTTP header to "application/zip". in: header required: true Loading @@ -1053,6 +1053,10 @@ components: in: path description: | Identifier of the individual NS descriptor resource. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new NS descriptor resource. It can also be retrieved from the "id" attribute in the message content of that response. required: true style: simple explode: false Loading @@ -1064,6 +1068,9 @@ components: in: path description: | Identifier of the individual PNF descriptor resource. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new PNF descriptor resource. It can also be retrieved from the "id" attribute in the message content of that response. required: true style: simple explode: false Loading Loading @@ -1130,7 +1137,7 @@ components: Identifier of this subscription. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new subscription resource. It can also be retrieved from the "id" attribute in the payload body of that response. from the "id" attribute in the message content of that response. required: true style: simple explode: false Loading Loading @@ -1201,7 +1208,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1243,7 +1250,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1289,7 +1296,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1324,7 +1331,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -1344,6 +1351,41 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string content: application/json: schema: Loading @@ -1362,7 +1404,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1449,7 +1491,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1479,12 +1521,12 @@ components: 200 OK Shall be returned when the content of the NSD has been read successfully. The payload body shall contain a copy of the ZIP file that contains the NSD file structure. The message content shall contain a copy of the ZIP file that contains the NSD file structure. The "Content-Type" HTTP header shall be set to "application/zip". headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1513,12 +1555,12 @@ components: shall be returned when a single consecutive byte range from the content of the NSD file has been read successfully according to the request. The response body shall contain the requested part of the NSD archive. The "Content-Range" HTTP header shall be provided according to IETF RFC 7233 [10]. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. The "Content-Type" HTTP header shall be set as defined above for the "200 OK" response. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1557,7 +1599,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1592,7 +1634,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1634,7 +1676,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1678,6 +1720,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string NsdArchiveContent.Put.409: description: | Loading Loading @@ -1706,7 +1782,7 @@ components: type: string Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -1721,7 +1797,7 @@ components: 200 OK Shall be returned when the content of the NSD has been read successfully. The payload body shall contain a copy of the file representing the NSD or The message content shall contain a copy of the file representing the NSD or a ZIP file that contains the file or multiple files representing the NSD, as specified above. The "Content-Type" HTTP header shall be set according to the format of Loading @@ -1729,7 +1805,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1801,7 +1877,7 @@ components: type: string Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -1819,18 +1895,18 @@ components: If the "include_signatures" URI query parameter was absent in the request, or if the manifest file has all security-related information embedded (i.e. there is no separate certificate file), the payload body shall contain a copy of the manifest file of the certificate file), the message content shall contain a copy of the manifest file of the NSD archive, and the "Content-Type" HTTP header shall be set to "text/plain". If the "include_signatures" URI query parameter was present in the related request and the manifest file does not have all the security-related information embedded (i.e. there is a separate certificate file), the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: and the message content shall contain a ZIP archive which includes: - a copy of the manifest file of the NSD archive; - a copy of the related individual certificate file. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1863,7 +1939,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1895,7 +1971,7 @@ components: Shall be returned when the content of the artifact file has been read successfully. If the "include_signatures" request URI parameter was not provided in the related request, the payload body shall contain a copy of the artifact file from the NSD archive, as defined the message content shall contain a copy of the artifact file from the NSD archive, as defined by ETSI GS NFV-SOL 007, and the "Content-Type" HTTP header shall be set according to the content type of the artifact file. If the artifact is encrypted, the header shall be set to the value "application/cms" (IETF RFC 7193). Loading @@ -1903,14 +1979,14 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octet-stream". If the "include_signatures" request URI parameter was provided in the related request, the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: and the message content shall contain a ZIP archive which includes: - a copy of the artifact file from the VNF package, as defined by ETSI GS NFVSOL 007 - the related security information (individual signature file and optional related individual certificate file). headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1947,11 +2023,11 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octet-stream". The "Content-Range" HTTP header shall be provided according to IETF RFC 7233. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1984,7 +2060,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2020,7 +2096,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2080,7 +2156,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2119,7 +2195,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2170,7 +2246,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2206,7 +2282,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -2226,6 +2302,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string content: application/json: schema: Loading Loading @@ -2286,12 +2396,12 @@ components: Shall be returned when the content of the PNFD archive has been read successfully. The payload body shall contain a copy of the PNFD archive The message content shall contain a copy of the PNFD archive The "Content-Type" HTTP header shall be set to "application/zip". headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2320,12 +2430,12 @@ components: when a single consecutive byte range from the content of the PNFD archive has been read successfully according to the request. The response body shall contain the requested part of the PNFD archive. The "Content-Range" HTTP header shall be provided according to IETF RFC 7233. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. The "Content-Type" HTTP header shall be set as defined above for the "200 OK" response. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2364,7 +2474,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2466,6 +2576,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string PnfdArchiveContent.Put.409: description: | Loading Loading @@ -2494,7 +2638,7 @@ components: type: string Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -2509,7 +2653,7 @@ components: 200 OK Shall be returned when the content of the PNFD has been read successfully. The payload body shall contain a copy of the file representing the PNFD The message content shall contain a copy of the file representing the PNFD or a ZIP file that contains the file or multiple files representing the PNFD, as specified above. The "Content-Type" HTTP header shall be set according to the format of Loading @@ -2517,7 +2661,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2575,7 +2719,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2608,20 +2752,20 @@ components: read successfully. If the "include_signatures" URI query parameter was absent in the request, or if the manifest file has all security-related information embedded (i.e. there is no separate certificate file), the payload body shall contain a copy of the manifest file of the PNFD archive, embedded (i.e. there is no separate certificate file), the message content shall contain a copy of the manifest file of the PNFD archive, and the "Content-Type" HTTP header shall be set to "text/plain". If the "include_signatures" URI query parameter was present in the related request and the manifest file does not have all the security-related information embedded (i.e. there is a separate certificate file), the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: the message content shall contain a ZIP archive which includes: - a copy of the manifest file of the PNFD archive; - a copy of the related individual certificate file. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2657,7 +2801,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2692,7 +2836,7 @@ components: Shall be returned when the content of the artifact file has been read successfully. If the "include_signatures" request URI parameter was not provided in the related request, the payload body shall contain a copy of the artifact file from the PNFD archive, as defined the message content shall contain a copy of the artifact file from the PNFD archive, as defined by ETSI GS NFV-SOL 004, and the "Content-Type" HTTP header shall be set according to the content type of the artifact file. If the artifact is encrypted, the header shall be set to the value "application/cms" (IETF RFC 7193). Loading @@ -2700,14 +2844,14 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octetstream". If the "include_signatures" request URI parameter was provided in the related request, the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: and the message content shall contain a ZIP archive which includes: - a copy of the artifact file from the VNF package, as defined by ETSI GS NFVSOL 004 - the related security information (individual signature file and optional related individual certificate file). headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2744,11 +2888,11 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octet-stream". The "Content-Range" HTTP header shall be provided according to IETF RFC 7233. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2780,7 +2924,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2813,7 +2957,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2848,7 +2992,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2881,7 +3025,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2924,7 +3068,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2953,10 +3097,10 @@ components: Subscriptions.Post.422: description: | 422 Unprocessable Entity 422 Unprocessable Content Shall be returned upon the following error: The content type of the payload body is supported and the payload body of a request contains syntactically correct data but the data cannot be processed. Shall be returned upon the following error: The content type of the message content is supported and the message content of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013 [16], including rules for the presence of the response body. Specifically in case of this resource, the response code 422 shall also be returned if the NFVO has tested Loading @@ -2966,7 +3110,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -3008,7 +3152,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -3058,7 +3202,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading
src/SOL005/APIVersion/APIVersion.yaml +2 −2 Viewed Changes for src/SOL005/APIVersion/APIVersion.yaml: 2 added lines, 2 removed lines. Original line number Diff line number Diff line Loading @@ -19,8 +19,8 @@ info: version: 1.0.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_nfv-sol005v030701p.pdf servers: - url: http://127.0.0.1/ Loading
src/SOL005/NFVICapacityInformation/definitions/NFVICapacityInformation_def.yaml +1 −1 Viewed Changes for src/SOL005/NFVICapacityInformation/definitions/NFVICapacityInformation_def.yaml: 1 added line, 1 removed line. Original line number Diff line number Diff line Loading @@ -227,7 +227,7 @@ components: type: object description: | This type defines the format of a time interval. The type shall comply with the provisions defined in table 10.5.2.7-1. NOTE: When only the startTime is present, there is no time interval being defined, and therefore the provided timing NOTE: When only the aTime is present, there is no time interval being defined, and therefore the provided timing information refers to a specific point in time. required: - aTime Loading
src/SOL005/NFVICapacityInformation/NFVICapacityInformation.yaml +45 −11 Viewed Changes for src/SOL005/NFVICapacityInformation/NFVICapacityInformation.yaml: 45 added lines, 11 removed lines. Original line number Diff line number Diff line Loading @@ -16,11 +16,11 @@ info: license: name: ETSI Forge copyright notice url: https://forge.etsi.org/etsi-forge-copyright-notice.txt version: 1.0.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 version: 1.1.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_NFV-SOL005v030701p.pdf servers: - url: http://127.0.0.1/nfvici/v1 Loading Loading @@ -315,7 +315,7 @@ components: description: | Identifier of the VIM with associated NFVI capacity information. This identifier can be retrieved from the "vimId" attribute in the CapacityShortageNotification. It can also be retrieved from the "vimId" attribute in the payload body of the response. It can also be retrieved from the "vimId" attribute in the message content of the response. required: true style: simple explode: false Loading @@ -329,7 +329,7 @@ components: Identifier of the capacity threshold. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new "Individual capacity threshold" resource. It can also be retrieved from the "id" attribute in the payload body of that response. attribute in the message content of that response. required: true style: simple explode: false Loading Loading @@ -498,11 +498,11 @@ components: CapacityThresholds.Post.422: description: | 422 UNPROCESSABLE ENTITY 422 Unprocessable Content Shall be returned upon the following error: The content type of the payload body is supported and the payload body of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013 [16], Shall be returned upon the following error: The content type of the message content is supported and the message content of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013, including rules for the presence of the response body. Specifically in case of this resource, the response code 422 shall also be returned if the NFVO has tested the Notification endpoint as described in clause 10.4.6.3.2 and the test has failed. Loading Loading @@ -592,6 +592,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string content: application/json: schema: Loading Loading @@ -630,9 +664,9 @@ components: IndividualCapacityThreshold.Patch.422: description: | 422 UNPROCESSABLE ENTITY 422 Unprocessable Content content type of the payload body is supported and the payload body of a request contains syntactically The content type of the message content is supported and the message content of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013 [16], including rules for the presence of the response body. Loading
src/SOL005/NFVICapacityInformationNotification/NFVICapacityInformationNotification.yaml +3 −3 Viewed Changes for src/SOL005/NFVICapacityInformationNotification/NFVICapacityInformationNotification.yaml: 3 added lines, 3 removed lines. Original line number Diff line number Diff line Loading @@ -16,11 +16,11 @@ info: license: name: ETSI Forge copyright notice url: https://forge.etsi.org/etsi-forge-copyright-notice.txt version: 1.0.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 version: 1.1.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_NFV-SOL005v030701p.pdf servers: - url: http://127.0.0.1/callback/v1 Loading
src/SOL005/NSDManagement/NSDManagement.yaml +225 −81 Viewed Changes for src/SOL005/NSDManagement/NSDManagement.yaml: 225 added lines, 81 removed lines. Original line number Diff line number Diff line Loading @@ -16,11 +16,11 @@ info: license: name: ETSI Forge copyright notice url: https://forge.etsi.org/etsi-forge-copyright-notice.txt version: 2.2.1-impl:etsi.org:ETSI_NFV_OpenAPI:1 version: 2.3.0-impl:etsi.org:ETSI_NFV_OpenAPI:1 externalDocs: description: ETSI GS NFV-SOL 005 V3.6.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.06.01_60/gs_nfv-sol005v030601p.pdf description: ETSI GS NFV-SOL 005 V3.7.1 url: https://www.etsi.org/deliver/etsi_gs/NFV-SOL/001_099/005/03.07.01_60/gs_NFV-SOL005v030701p.pdf servers: - url: http://127.0.0.1/nsd/v2 Loading @@ -37,7 +37,7 @@ paths: # NS Descriptors # ############################################################################### /ns_descriptors: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.2 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.2 parameters: - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization - $ref: ../components/SOL005_params.yaml#/components/parameters/Version Loading Loading @@ -128,7 +128,7 @@ paths: # Individual NS Descriptor # ############################################################################### /ns_descriptors/{nsdInfoId}: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.3 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.3 parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -224,7 +224,7 @@ paths: # NSD Archive Content # ############################################################################### /ns_descriptors/{nsdInfoId}/nsd_content: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.4 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4 parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -297,7 +297,7 @@ paths: # NSD # ############################################################################### /ns_descriptors/{nsdInfoId}/nsd: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.4a #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4a parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -337,7 +337,7 @@ paths: # NSD Archive Manifest # ############################################################################### /ns_descriptors/{nsdInfoId}/manifest: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.4b #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4b parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -387,7 +387,7 @@ paths: # Individual NSD Archive Artifact # ############################################################################### /ns_descriptors/{nsdInfoId}/artifacts/{artifactPath}: #ETSI GS NFV-SOL 005 V3.5.1 location: 5.4.4c #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.4c parameters: - $ref: '#/components/parameters/NsdInfoId' - $ref: '#/components/parameters/ArtifactPathInNSD' Loading Loading @@ -439,7 +439,7 @@ paths: # PNF Descriptors # ############################################################################### /pnf_descriptors: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.5 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.5 parameters: - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization - $ref: ../components/SOL005_params.yaml#/components/parameters/Version Loading Loading @@ -530,7 +530,7 @@ paths: # Individual PNF Descriptor # ############################################################################### /pnf_descriptors/{pnfdInfoId}: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.6 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.6 parameters: - $ref: '#/components/parameters/PnfdInfoId' Loading Loading @@ -624,7 +624,7 @@ paths: # PNFD Archive Content # ############################################################################### /pnf_descriptors/{pnfdInfoId}/pnfd_content: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.7 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7 parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -698,7 +698,7 @@ paths: # PNFD # ############################################################################### /pnf_descriptors/{pnfdInfoId}/pnfd: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.7a #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7a parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -739,7 +739,7 @@ paths: # PNFD Archive Manifest # ############################################################################### /pnf_descriptors/{pnfdInfoId}/manifest: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.7b #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7b parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -791,7 +791,7 @@ paths: # Individual PNFD Archive Artifact # ############################################################################### /pnf_descriptors/{pnfdInfoId}/artifacts/{artifactPath}: #ETSI GS NFV-SOL 005 V3.5.1 location: 5.4.7c #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.7c parameters: - $ref: '#/components/parameters/PnfdInfoId' - $ref: '#/components/parameters/ArtifactPathInPNFD' Loading Loading @@ -842,7 +842,7 @@ paths: # Subscriptions # ############################################################################### /subscriptions: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.8 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.8 parameters: - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization - $ref: ../components/SOL005_params.yaml#/components/parameters/Version Loading Loading @@ -924,7 +924,7 @@ paths: # Individual Subscription # ############################################################################### /subscriptions/{subscriptionId}: #ETSI GS NFV-SOL 005 V2.4.1 location: 5.4.9 #ETSI GS NFV-SOL 005 V3.7.1 location: 5.4.9 parameters: - $ref: '#/components/parameters/SubscriptionId' - $ref: ../components/SOL005_params.yaml#/components/parameters/Authorization Loading Loading @@ -1039,7 +1039,7 @@ components: ContentTypeZip: name: Content-Type description: | The payload body contains a ZIP file that represents the NSD archive, as specified above. The message content contains a ZIP file that represents the NSD archive, as specified above. The request shall set the "Content-Type" HTTP header to "application/zip". in: header required: true Loading @@ -1053,6 +1053,10 @@ components: in: path description: | Identifier of the individual NS descriptor resource. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new NS descriptor resource. It can also be retrieved from the "id" attribute in the message content of that response. required: true style: simple explode: false Loading @@ -1064,6 +1068,9 @@ components: in: path description: | Identifier of the individual PNF descriptor resource. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new PNF descriptor resource. It can also be retrieved from the "id" attribute in the message content of that response. required: true style: simple explode: false Loading Loading @@ -1130,7 +1137,7 @@ components: Identifier of this subscription. This identifier can be retrieved from the resource referenced by the "Location" HTTP header in the response to a POST request creating a new subscription resource. It can also be retrieved from the "id" attribute in the payload body of that response. from the "id" attribute in the message content of that response. required: true style: simple explode: false Loading Loading @@ -1201,7 +1208,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1243,7 +1250,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1289,7 +1296,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1324,7 +1331,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -1344,6 +1351,41 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string content: application/json: schema: Loading @@ -1362,7 +1404,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1449,7 +1491,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1479,12 +1521,12 @@ components: 200 OK Shall be returned when the content of the NSD has been read successfully. The payload body shall contain a copy of the ZIP file that contains the NSD file structure. The message content shall contain a copy of the ZIP file that contains the NSD file structure. The "Content-Type" HTTP header shall be set to "application/zip". headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1513,12 +1555,12 @@ components: shall be returned when a single consecutive byte range from the content of the NSD file has been read successfully according to the request. The response body shall contain the requested part of the NSD archive. The "Content-Range" HTTP header shall be provided according to IETF RFC 7233 [10]. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. The "Content-Type" HTTP header shall be set as defined above for the "200 OK" response. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1557,7 +1599,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1592,7 +1634,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1634,7 +1676,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1678,6 +1720,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string NsdArchiveContent.Put.409: description: | Loading Loading @@ -1706,7 +1782,7 @@ components: type: string Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -1721,7 +1797,7 @@ components: 200 OK Shall be returned when the content of the NSD has been read successfully. The payload body shall contain a copy of the file representing the NSD or The message content shall contain a copy of the file representing the NSD or a ZIP file that contains the file or multiple files representing the NSD, as specified above. The "Content-Type" HTTP header shall be set according to the format of Loading @@ -1729,7 +1805,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1801,7 +1877,7 @@ components: type: string Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -1819,18 +1895,18 @@ components: If the "include_signatures" URI query parameter was absent in the request, or if the manifest file has all security-related information embedded (i.e. there is no separate certificate file), the payload body shall contain a copy of the manifest file of the certificate file), the message content shall contain a copy of the manifest file of the NSD archive, and the "Content-Type" HTTP header shall be set to "text/plain". If the "include_signatures" URI query parameter was present in the related request and the manifest file does not have all the security-related information embedded (i.e. there is a separate certificate file), the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: and the message content shall contain a ZIP archive which includes: - a copy of the manifest file of the NSD archive; - a copy of the related individual certificate file. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1863,7 +1939,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1895,7 +1971,7 @@ components: Shall be returned when the content of the artifact file has been read successfully. If the "include_signatures" request URI parameter was not provided in the related request, the payload body shall contain a copy of the artifact file from the NSD archive, as defined the message content shall contain a copy of the artifact file from the NSD archive, as defined by ETSI GS NFV-SOL 007, and the "Content-Type" HTTP header shall be set according to the content type of the artifact file. If the artifact is encrypted, the header shall be set to the value "application/cms" (IETF RFC 7193). Loading @@ -1903,14 +1979,14 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octet-stream". If the "include_signatures" request URI parameter was provided in the related request, the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: and the message content shall contain a ZIP archive which includes: - a copy of the artifact file from the VNF package, as defined by ETSI GS NFVSOL 007 - the related security information (individual signature file and optional related individual certificate file). headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1947,11 +2023,11 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octet-stream". The "Content-Range" HTTP header shall be provided according to IETF RFC 7233. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -1984,7 +2060,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2020,7 +2096,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2080,7 +2156,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2119,7 +2195,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2170,7 +2246,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2206,7 +2282,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -2226,6 +2302,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string content: application/json: schema: Loading Loading @@ -2286,12 +2396,12 @@ components: Shall be returned when the content of the PNFD archive has been read successfully. The payload body shall contain a copy of the PNFD archive The message content shall contain a copy of the PNFD archive The "Content-Type" HTTP header shall be set to "application/zip". headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2320,12 +2430,12 @@ components: when a single consecutive byte range from the content of the PNFD archive has been read successfully according to the request. The response body shall contain the requested part of the PNFD archive. The "Content-Range" HTTP header shall be provided according to IETF RFC 7233. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. The "Content-Type" HTTP header shall be set as defined above for the "200 OK" response. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2364,7 +2474,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2466,6 +2576,40 @@ components: explode: false schema: type: string ETag: description: | Etag used in the header response. style: simple explode: false schema: type: string Last-Modified: description: | Last-modified used in the header response. style: simple explode: false schema: type: string If-Unmodified-Since: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string If-Match: description: | Response header available in case the related "Last-Modified" or "ETag" headers have been received in previous responses related to the target resource. The API consumer should provide the "If-Unmodified-Since" or the "If-Match" header fields as conditions (see sections 3.1 and 3.4 of IETF RFC 9110). style: simple explode: false schema: type: string PnfdArchiveContent.Put.409: description: | Loading Loading @@ -2494,7 +2638,7 @@ components: type: string Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading @@ -2509,7 +2653,7 @@ components: 200 OK Shall be returned when the content of the PNFD has been read successfully. The payload body shall contain a copy of the file representing the PNFD The message content shall contain a copy of the file representing the PNFD or a ZIP file that contains the file or multiple files representing the PNFD, as specified above. The "Content-Type" HTTP header shall be set according to the format of Loading @@ -2517,7 +2661,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2575,7 +2719,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2608,20 +2752,20 @@ components: read successfully. If the "include_signatures" URI query parameter was absent in the request, or if the manifest file has all security-related information embedded (i.e. there is no separate certificate file), the payload body shall contain a copy of the manifest file of the PNFD archive, embedded (i.e. there is no separate certificate file), the message content shall contain a copy of the manifest file of the PNFD archive, and the "Content-Type" HTTP header shall be set to "text/plain". If the "include_signatures" URI query parameter was present in the related request and the manifest file does not have all the security-related information embedded (i.e. there is a separate certificate file), the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: the message content shall contain a ZIP archive which includes: - a copy of the manifest file of the PNFD archive; - a copy of the related individual certificate file. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2657,7 +2801,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2692,7 +2836,7 @@ components: Shall be returned when the content of the artifact file has been read successfully. If the "include_signatures" request URI parameter was not provided in the related request, the payload body shall contain a copy of the artifact file from the PNFD archive, as defined the message content shall contain a copy of the artifact file from the PNFD archive, as defined by ETSI GS NFV-SOL 004, and the "Content-Type" HTTP header shall be set according to the content type of the artifact file. If the artifact is encrypted, the header shall be set to the value "application/cms" (IETF RFC 7193). Loading @@ -2700,14 +2844,14 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octetstream". If the "include_signatures" request URI parameter was provided in the related request, the "Content-Type" HTTP header shall be set to "application/zip" and the payload body shall contain a ZIP archive which includes: and the message content shall contain a ZIP archive which includes: - a copy of the artifact file from the VNF package, as defined by ETSI GS NFVSOL 004 - the related security information (individual signature file and optional related individual certificate file). headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2744,11 +2888,11 @@ components: If the content type cannot be determined, the header shall be set to the value "application/octet-stream". The "Content-Range" HTTP header shall be provided according to IETF RFC 7233. The "Content-Range" HTTP header shall be provided according to IETF RFC 9110. headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2780,7 +2924,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2813,7 +2957,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2848,7 +2992,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2881,7 +3025,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2924,7 +3068,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -2953,10 +3097,10 @@ components: Subscriptions.Post.422: description: | 422 Unprocessable Entity 422 Unprocessable Content Shall be returned upon the following error: The content type of the payload body is supported and the payload body of a request contains syntactically correct data but the data cannot be processed. Shall be returned upon the following error: The content type of the message content is supported and the message content of a request contains syntactically correct data but the data cannot be processed. The general cause for this error and its handling is specified in clause 6.4 of ETSI GS NFV-SOL 013 [16], including rules for the presence of the response body. Specifically in case of this resource, the response code 422 shall also be returned if the NFVO has tested Loading @@ -2966,7 +3110,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -3008,7 +3152,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading Loading @@ -3058,7 +3202,7 @@ components: headers: Content-Type: description: | The MIME type of the body of the request. Reference: IETF RFC 7231 The MIME type of the body of the request. Reference: IETF RFC 9110 style: simple explode: false schema: Loading