Commit 15d16283 authored by YannGarcia's avatar YannGarcia
Browse files

Bug fixed in build scripts

parent 5a76dcaf
......@@ -239,9 +239,13 @@ sed --in-place "${ADD_RUN_LINE_2}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -241,9 +241,13 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -241,9 +241,18 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" == "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -241,9 +241,13 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -241,9 +241,13 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -246,7 +246,7 @@ then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
......
......@@ -241,9 +241,13 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -241,9 +241,13 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
......@@ -241,9 +241,13 @@ sed --in-place "${ADD_RUN_LINE_3}" ./Makefile
# Build all
make all 2>&1 3>&1 | tee --append build.log
if [ "$?" == "1" ]
if [ "$?" != "0" ]
then
f_exit "Failed to generate ATS source code" 9
fi
../bin/Ats${ATS_NAME} -v
if [ "$?" != "0" ]
then
f_exit "Failed to executte binary file Ats${ATS_NAME}" 10
fi
f_exit "Build done successfully" 0
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment