Commit c2da30f6 authored by moscatelli's avatar moscatelli
Browse files

SOL005_6 and SOL005_7: Version added in response and request headers in NS fault mgmt interface

parent 9351ac0f
Pipeline #506 passed with stage
in 0 seconds
......@@ -99,7 +99,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
200:
......@@ -129,7 +129,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
schema:
type: array
items:
......@@ -188,7 +188,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
- name: "body"
in: "body"
......@@ -238,7 +238,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400"
401:
......@@ -300,7 +300,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
200:
......@@ -334,7 +334,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400-attr-selector"
401:
......@@ -400,7 +400,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
200:
......@@ -430,7 +430,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
schema:
type: array
items:
......@@ -479,7 +479,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
204:
......@@ -502,7 +502,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400-attr-selector"
401:
......@@ -587,7 +587,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
200:
......@@ -622,7 +622,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
206:
$ref: "responses/SOL005_resp.yaml#/responses/206"
400:
......@@ -690,7 +690,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
202:
......@@ -721,7 +721,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
204:
description: >
204 No Content
......@@ -811,7 +811,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
200:
......@@ -841,7 +841,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
schema:
type: "array"
items:
......@@ -912,7 +912,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
201:
......@@ -951,7 +951,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
206:
$ref: "responses/SOL005_resp.yaml#/responses/206"
400:
......@@ -1015,7 +1015,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
responses:
200:
......@@ -1044,7 +1044,7 @@ paths:
Version of the API used in the response.
type: string
maximum: 1
minimum: 0
minimum: 1
schema:
type: "object"
properties:
......@@ -1142,7 +1142,7 @@ paths:
description: >
Version of the API requested to use when responding to this request.
in: header
required: false
required: true
type: string
- name: "body"
in: "body"
......
......@@ -71,6 +71,12 @@ paths:
in: header
required: false
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
200:
description: >
......@@ -92,6 +98,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
schema:
type: array
items:
......@@ -155,6 +167,12 @@ paths:
in: header
required: false
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
200:
description: >
......@@ -177,6 +195,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
schema:
properties:
Alarm:
......@@ -237,6 +261,12 @@ paths:
required: true
type: string
enum: ["application/merge-patch+json"]
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
200:
description: >
......@@ -259,6 +289,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
schema:
properties:
AlarmModifications:
......@@ -320,6 +356,12 @@ paths:
in: header
required: true
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
- name: "body"
in: "body"
required: true
......@@ -363,6 +405,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
303:
$ref: "responses/SOL005_resp.yaml#/responses/303"
400:
......@@ -424,6 +472,12 @@ paths:
in: header
required: true
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
200:
description: >
......@@ -447,6 +501,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
schema:
type: array
items:
......@@ -516,6 +576,12 @@ paths:
in: header
required: true
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
200:
description: >
......@@ -540,6 +606,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
schema:
properties:
FmSubscription:
......@@ -572,6 +644,12 @@ paths:
in: header
required: false
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
204:
description: >
......@@ -588,6 +666,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400"
401:
......@@ -646,6 +730,12 @@ paths:
in: header
required: true
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
204:
description: >
......@@ -662,6 +752,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400"
401:
......@@ -710,6 +806,12 @@ paths:
in: header
required: true
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
204:
description: >
......@@ -726,6 +828,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400"
401:
......@@ -774,6 +882,12 @@ paths:
in: header
required: true
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
204:
description: >
......@@ -790,6 +904,12 @@ paths:
has provided an invalid authorization token.
maximum: 1
minimum: 0
Version:
description: >
Version of the API used in the response.
type: string
maximum: 1
minimum: 1
400:
$ref: "responses/SOL005_resp.yaml#/responses/400"
401:
......@@ -821,6 +941,12 @@ paths:
in: header
required: false
type: string
- name: Version
description: >
Version of the API requested to use when responding to this request.
in: header
required: true
type: string
responses:
204:
description: >
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment