Commit 26fdad43 authored by Ken Coar's avatar Ken Coar
Browse files

Add a FAQ about Y2K compliance.

Submitted by:	Lars Eilebrecht <Lars.Eilebrecht@unix-ag.org>


git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@79284 13f79535-47bb-0310-9956-ffa450edef68
parent e5546994
Loading
Loading
Loading
Loading
+51 −2
Changes for docs/manual/misc/FAQ.html: 51 added lines, 2 removed lines.
Original line number Diff line number Diff line
@@ -15,7 +15,7 @@
  <!--#include virtual="header.html" -->
  <H1 ALIGN="CENTER">Apache Server Frequently Asked Questions</H1>
  <P>
  $Revision: 1.88 $ ($Date: 1997/09/17 16:32:21 $)
  $Revision: 1.89 $ ($Date: 1997/09/18 13:00:15 $)
  </P>
  <P>
  The latest version of this FAQ is always available from the main
@@ -252,6 +252,8 @@
   <LI><A HREF="#cgi-spec">Where can I find the &quot;CGI
    specification&quot;?</A>
   </LI>
   <LI><A HREF="#year2000">Is Apache Year 2000 compliant?</A>
   </LI>
  </OL>
 </LI>
</UL>
@@ -1354,7 +1356,9 @@
  <A HREF="../mod/core.html#serverroot">ServerRoot</A>
  directory. As of Apache version 1.3, the location can be set <EM>via</EM>
  the
  <A HREF="../mod/core.html#coredumpdirectory">CoreDumpDirectory</A>
  <A
   HREF="../mod/core.html#coredumpdirectory"
  ><SAMP>CoreDumpDirectory</SAMP></A>
  directive to a different directory. Make sure that this directory is
  writable by the user the server runs as (as opposed to the user the server
  is <EM>started</EM> as).
@@ -2054,6 +2058,51 @@
  </P>
  <HR>
 </LI>
 <LI><A NAME="year2000">
      <STRONG>Is Apache Year 2000 compliant?</STRONG>
     </A>
  <P>
  Yes, Apache is Year 2000 compliant.
  </P>
  <P>
  Apache internally never stores years as two digits.
  On the HTTP protocol level RFC1123-style addresses are generated
  which is the only format a HTTP/1.1-compliant server should
  generate. To be compatible with older applications Apache
  recognizes ANSI C's <CODE>asctime()</CODE> and
  RFC850-/RFC1036-style date formats, too.
  The <CODE>asctime()</CODE> format uses four-digit years,
  but the RFC850 and RFC1036 date formats only define a two-digit year.
  If Apache sees such a date with a value less than 70 it assumes that
  the century is <SAMP>20</SAMP> rather than <SAMP>19</SAMP>.
  </P>
  <P>
  Some aspects of Apache's output may use two-digit years, such as the
  automatic listing of directory contents provided by
  <A
   HREF="../mod/mod_autoindex.html"
  ><SAMP>mod_autoindex</SAMP></A>
  with the
  <A
   HREF="../mod/mod_autoindex.html#indexoptions"
  ><SAMP>FancyIndexing</SAMP></A>
  option enabled, but it is improper to depend upon such displays for
  specific syntax.  And even that issue is being addressed by the
  developers; a future version of Apache should allow you to format that
  display as you like.
  </P>
  <P>
  Although Apache is Year 2000 compliant, you may still get problems
  if the underlying OS has problems with dates past year 2000
  (<EM>e.g.</EM>, OS calls which accept or return year numbers).
  Most (UNIX) systems store dates internally as signed 32-bit integers
  which contain the number of seconds since 1<SUP>st</SUP> January 1970, so
  the magic boundary to worry about is the year 2038 and not 2000.
  But modern operating systems shouldn't cause any trouble
  at all.
  </P>
  <HR>
 </LI>

  <!-- Don't forget to add HR tags at the end of each list item.. -->